Airplay not working

I have just setup an rpi3 with Allo DigiOne Signature, connected to ethernet & via SPDIF to a pair of Meridian DSP speakers.

Playback from Roon is working just fine as is via the Spotify Desktop app, on my Macbook.

Airplay does not work. My Macbook is on the same network as the rpi (via wifi) I see the Airplay icon disappear & then reappear on my Macbook, when I reboot the rpi but when I click on it the Airplay icon, I see “Airplay: looking for TV”. I do see an entry “ropieexl [RoPieeeXL]” in the Audio settings on my Macbook. Clicking on this does not result in me being able to direct the sound from my browser (on through my speakers.

On my iPhone, I can see & switch to the same Airplay entity (ropieexl [RoPieeeXL]) from Control Centre, but I hear nothing through the speakers when I then initiate playback from the Spotify app.

I made this switch from a Meridian streaming device to get the benefit of playing Soundcloud via Airplay. Also, it is appealing for me to be able to give my family access to my speakers via their iPhones (so Airplay again) Please help, if you can.


Have you configured Airplay output correctly?

Thanks for responding!

Audio Output is set to ‘HAT’
Volume Control is set to ‘Disabled’

An iPhone & iPad actually do work now, since I moved the ethernet connection from the rpi directly into my wifi router, as opposed to into a 8-port hub connected to the router, where it had been.

Airplay still does not work on either of two Macbooks I have.

Hi spockfish - i am using a hifiberry digi+ on a pi4, same issue I can’t see the ropieeexl on airplay.
everything is working find on room. what do you mean by have you configured the airplay output correctly? where would i do that please? I have read the
thoroughly. I think I must be missing something obvious.
thanks Pete

Have you looked at the settings for Airplay in the webinterface?

1 Like

Hi Harry - I was being a little slow - found the tab. All is working beautifully now. Testing it with Warren Zevon at the moment. Donation should have reached you too. Cheers Pete

1 Like

So what was the solution? I am having the same problem :sob:

Go to to ropieee tab then the shairpot-sync tab and turn on the hat there
Hope that helps