Airplay on HomePods won't skip/pause/stop via Siri or other AirPlay-based controls [Ticket In]

Core Machine (Operating system/System info/Roon build number)

Core is a late 2012 Mac Mini, MacOS Sierra (10.12.6), running Roon Server 1.6 (build 710)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Core is connected via ethernet to an Eero; the endpoints at issue (multiple HomePods) are on the Eero wi-fi network

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

HomePods via Airplay. OS 14.3 (latest)

Description Of Issue

This has been a problem for a couple months, but I’m just getting around to raising it. Previously, when playing Roon through a HomePod, I could skip tracks, pause, or stop the music through Siri commands. At some point, that stopped working. The music plays fine, but when I ask Siri to skip a track, nothing happens, and when I ask Siri to stop the music, it says that nothing is playing. These functions work fine when playing other AirPlay sources (e.g., Tidal on my phone) through our HomePods. One odd thing: when I ask Siri to change the volume, the response is to the effect that the media volume has been changed, which is what Siri says when nothing is playing, although in this case there is music playing (and the volume does change accordingly); with other AirPlay sources, the volume changes without any Siri announcement.

Similarly, when I play Roon on a HomePod, the track information and cover art shows on my iPhone’s “Control Other Speakers & TVs” function, but the controls on that screen (pause/skip track) do not work, although they did in the past.

In Home.app, Home settings are set to allow “Anyone on the Same Network” to access speakers, so that’s not the problem, I think.

Bottom line: music streaming to these endpoints works fine, but somehow the control plane is messed up.

1 Like

Hi @amg,

Thanks for reaching out! I’ve put in a request to our hardware team regarding your case as they would have the most accurate information.

It may take bit of time to hear back due to the holidays, but in the meantime have you tried to factory-reset the Homepods? If not, I would give that a try!

Thanks, @noris. I just did a factory reset of one of the HomePods, and it did not change anything.

1 Like

Hello @amg,

Thanks for confirming that the factory reset didn’t help here. I spoke to our hardware team and they have confirmed that there’s been some changes on Apple’s side here, they’ve increased security with regard to Airplay commands and we’re filed a ticket for the team to investigate this behavior further.

Hi everybody,

I’ve got the same trouble too, with my Bluesound Speakers and my HomePod Mini !
I already tried to reset my speakers without result and Roon 1.8 does not change this problem.

The hardware team does have a way to fix it ?

Thank you !

I’ve had the same problem for months-- I can start roon through the homepods around the house and i can control volume on the homepods but i can’t stop the music by tapping the devices and Siri does not recognize any music playing (so can’t stop or skip, etc).

I use these for Roon endpoints and this really limits functionality so a fix from Roon would be appreciated! The thread above suggests that Apple changed security on these and now Roon needs to update somehow?

thank you!

Is it possible to get an update on this, please? “Hey Siri, pause the music” is a ridiculously basic thing any Airplay source should be able to adhere to and has been missing for months.

Thanks,

Hello @Yargi_Erel ,

Thanks for pinging us on this! I had a chance to discuss this behavior with the team and we have been able to reproduce this behavior in the lab and are investigating this further. Thanks in advance for your patience!

1 Like

Hey @noris, any chance there’s any progress planned on Siri controls in the coming releases?
Just complying with Play/Pause will be a massive improvement.

Thanks,

2 Likes

Same here 4 HomePods grouped and no ability to control these devices via Siri commands

Hi All,

Thanks for the reports here, we are still looking into this and have an active ticket. I can’t comment on timelines of when the work for the ticket will be done, but I do see that the ticket is in the queue. Thanks in advance for your pateince!