AirPlay Sync Issues on Roon with macOS and Various Audio Devices (ref#13WMB5)

Affected Product

Roon

Roon Issue Category

Playback

Description of Issue

AirPlay keeps going out of sink on my Group over AirPlay Atom+ Zeppelin+2 HomePod mini‘s

I have to pause playback and resume to get it back in sync this is not a constant issue. It happens every three or four tracks. but it is random

Roon Server Platform

macOS

Roon Server Specifications

Mac Mini M1 16 GB MacOS Version 14.2.1 music collection stored on NAS Synology DS918+

Connected Audio Devices

(Cat 6) Naim Atom, Zeppelin Air, Yamaha RX-V673 (WiFi) 1x Zuma 5x HomePod mini‘s

Home Network Details

Synology RT6600ax link with WRX560 Over Cat 6 Mesh set up

Hi @GillysHere,
Thank you for your patience while we worked through the queue. Can you give more details about your network setup? You have two routers listed in your network. Is one being used in bridge mode? Additionally, are you using Private Relay or Private WiFi?

Hi daniel

Thank you for getting back, It’s just happened again while I am typing it seems to be when it starts the next track and it is just the Naim Atom out of sink the Zeppelin Air and the 2 HomePods seem to be in sink if this helps,

My WiFi set up is Synology RT66000ax Wired Uplink to a Synology WRX560 in a Mesh set up

My set up



No Bridge mode.
No Private Relay or Private WiFi

Looking where Roon is on the Mac Mini on Ethernet & Wi-Fi looks link are both on the RT66000ax & My Zeppelin Air is on Cat 6 My Naim Atom is on Cat 6 are showing on the RT66000ax, In the living room the WRX560 is connecting to the 2 HomePod Minis at lest this is how I think it is connecting with AirPlay


Hi @GillysHere,
Thanks for all of the screenshots they are helpful. We are enabling some advanced diagnostics on your account. Please reboot your server twice and then when the sync issue occurs again let us know the date, local time, and track playing when the sync error occurs.

Thank you, silly question I can’t seem to find anywhere a restart just quit so I have quit the program and restarted the program twice. I hope this will suffice. I will let you know soon. If I’ve done this incorrectly please let me know thank you.

Here is a screenshot from the IPad I’m in the UK. Date, time (GMT) and track are all on this

I paused and resumed which got it back in sync but this time it happened quicker than normal here is another instance it’s happened on this screenshot.

And agin here

@GillysHere I want to narrow down exactly where this is happening so we have 2 tests. First, try using this app to group your airplay devices and see if the sync problems happen with that.

The second test is to try to group two endpoints at a time and try playing to see if it’s a particular combination of airplay endpoints that causes the problem.

Hi Just letting you know I am trying to get this done, but at the moment we are busier than normal so I have less time, I had a go at getting this particular app on my Mac Mini M1 but he is asking me to do a number of things to get it on starting up in backups and all sorts of stuff. Can I not do this from dirt I say it iTunes ? If this particular app is the only way, I will try another day to get this on my Mac.

We want to test group play independently of Roon to narrow down if this is a Roon problem or not. The app I recommended is one that I know supports grouped play. If that one doesn’t work for you another app that supports grouping AirPlay devices would work as well. I don’t know of any off-hand though.

Ok I understand So I had a A little spare time today, I got the software installed and tested it, There was no out of sink happening at all, however it did keep dropping the 2 AirPod mini’s (Garage+Kitchen) on the 2 test I did. The Zeppelin Air & Atom keeps working as normal I also put Apple Music on and applied from that the same thing happened on here.

Working


Dropped 2 (Garage+Kitchen) after 5 mints ish second test was nearly straight away.


So I did more tests on Roon I have Group in a different order don’t know if this will make any difference, but I give it a try… Zeppelin Air (Dining Room) & Atom then the 2 AirPod mini’s its goes out of sink here

Now I just do the Zeppelin Air (Dining Room) & Atom I Didn’t leave it more than four tracks as it seem to be keeping in sync longer than it had been doing.

So next I put the 2 AirPod mini’s (Garage+Kitchen) on the 2 I Didn’t leave it more than four tracks as it seem to be keeping in sync as well So it just when Group, the two together I have seen problems.

Since I started using Roon, I’ve not had any sinking issues before so I do not understand why this is happening now?

Thanks for your continued cooperation and all of that information. The sync issue is Roon-related based on the information you’ve provided. I’ll be bringing this to the dev team and will get back to you with the next steps.

In the meantime please try a hard reboot of the HomePods. To do a hard reboot unplug the HomePods for 30 seconds and then plug them back in.

Ok thank you just a quick update. I have hard rebooted the 2 AirPod minis which has helped a little got a few hours without sink problems, but unfortunately it started happening again.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Hi @GillysHere,
Sorry this ticket got a bit lost. Are you still having sync issues?

Hi,

My sinking problems are 90% better since your latest update. I do still get this happening, which is still frustrating, Pausing the track and restarting the track puts everything back in sink so I still have a problem that needs addressing

Hi again @daniel

So I I’m the new 2.0 (build 1432) and was excited to start using AirPlay2 unfortunately, my first generation Zeppelin Air which is on AirPlay as you will know :slightly_smiling_face: is so out of sink It’s unplayable with the rest of my speakers :slightly_frowning_face: I have to leave it off. I used to be able to skip to the next track to get it back in sink. That is not possible now it just does not work in sink at all I have tried the obvious of rebooting all the speakers and My Mac mini M1 running Roon. On the other hand, everything with AirPlay2 please flawlessly with no out of sync happening at all so this is Great, but I am a speaker Down in my Open plan living space so is a big gap in my set up, Will I need to open a new ticket or shall we just carry on on this original ticket ??? I know you are all Busy, but I’d prefer not to wait a few months for your reply this time thanks in advance.

I don’t know if it helps but you could try enabling the new compatibility mode for older Airplay devices. It’s in the device setup under Advanced:

Thank you @Suedkiez for your suggestion, didn’t even know that was a new setting. I have just given it a try, but unfortunately, this did not work the old device is still out of sync :frowning_face:

I don’t know why they didn’t mention it in the release notes :person_shrugging: It was added during Early Access testing because some old devices wouldn’t work any other way, so one would think it’s worth mentioning.

Sorry it doesn’t help :slight_smile: Something for official support, I suppose.

Yes it may be helpful for some users knowing this, Thank you for suggestion was definitely worth a try :+1:

1 Like