Airplay via Ropieee XL not working on pi2aes over BNC [SOLVED]

Thanks for the great project! As the title says, here’s my identifier: 5f7283ed988ab19f

EDIT: I’ll elaborate that the Airplay connection happens successfully and stays connected. There just isn’t any output.

  • Brandon

Does the output work when using RAAT (Roon)?

Yeah it works wonderfully!

And, have you set the audio output for AirPlay correctly (the RoPieeeXL tab)? Just guessing on the problem.

I believe so, first thing I did. I’ll attach a screenshot, I tried allowing volume control, but that didn’t make a difference.

He @hells,

The logs seem ok, except that I don’t see any interaction because you’re sending music to it.

Can you do the following:

  • switch to the beta channel (go to the ‘advanced’ tab)
  • update it it (it will show up after the reboot)
  • try again playing audio
  • send me feedback


@spockfish Hey Harry, upgraded to Beta (looks like it’s using a different airplay program? Shairport Sync) and no dice. Here’s the feedback: 2414e79e67ed6043


@spockfish Hey it’s been a while, decided to try airport on the latest (3.020 XL) here’s my identifier: c592a115427ed70d, same deal, I can connect to the airplay endpoint, click play on something and no audio.

I see data coming in, but also messages about sync issues.

Can’t find too much about this, but I do see some remarks about possible problems with multicast which might result from router/firewall configs being too strict.

Oh man that was it! I could hear my DAC click to adjust to the sample rate (Schiit Gungnir MB) so I thought everything was OK connection wise, never thought to look into that angle further. The pi resides on a different vlan, so I troubleshooted by putting them on the same one and it worked! Which brought me to this excellent page for what rules were needed for Airplay to work cross vlan:

Essentially this bit:

    OUTBOUND: Allow AirPlay devices to send TCP traffic originating from SRC port 7000 to any DST port on any client on the Main LAN

    OUTBOUND: Allow AirPlay devices to send UDP traffic originating from SRC ports 6002 & 49152-65535 to any DST port on any client on the Main LAN

I suppose it must have been having issues “syncing” not necessarily connecting. Odd as other AirPlay activities on other devices worked fine in the same vlan. But who cares, I also disabled IGMP snooping, that may have played a part, but didn’t fix it on it’s own.

Thanks Harry! Love your project.

EDIT: Are we able to mark this topic as SOLVED somewhere I’m missing?

You can change the title and add [SOLVED]

Yeah I can’t seem to find where to edit a topic title. Seems like I can’t.

Hi @hells, your account on here does not have the required trust-level yet, so I’ve updated for you.