Alarm Clock extension not working / incorrect day


I just tried using the Alarm Clock extension with RopieeeXL 2.536 beta and am having trouble getting it to work after a reboot of the Ropieee Pi.

As an experiment, I set an alarm for +5 minutes and then rebooted the pi. When I looked at the Alarm Extension settings on my Mac after the reboot, the date of the alarm was the previous day (Sunday rather than today, i.e. Monday).

As an experiment, I tried installing the Alarm extension Docker container on another pi running Buster and made the same alarm. After rebooting that Pi, the date was set correctly and the alarm functioned properly.

I am based in the UK if it makes a difference.

Ok. I just updated it without testing, so that requires some investigation.

Thanks Harry. I had actually tried the alarm clock a while ago and never succeeded in getting it to work, so I don’t think it’s down to the recent upgrade.

The symptoms seem to be the same as Alarm clock "reset" on RoPieee reboot.

Ow. Totally missed that post.

I am not sure this helps, but I noticed for awhile (historically) if my endpoint rebooted in the night (3am Pacific), the alarm would go off because it thought that it was 7am. I fixed this by changing the reboot time to later. I have no evidence for this, but it seemed that the alarm reset to GMT (or CET or …) internally while displaying correctly.

Another thing that I took to doing is saving the alarm settings after a RoPieee update (or Roon core update).

In any case, my alarm worked as expected after the upgrade to beta last night.

1 Like

Mine reboots daily at the default time of 03:04 so that might fit.

Hi @jimbo,

If you’re still on the beta channel can you confirm this issue to be solved?


Hi Harry,

I was away from home at the weekend but will check tomorrow morning and let you know.


1 Like

Hi Harry,

I’m still not sure. The alarm didn’t go off this morning, but this might have been due to some network issues I was having, as it worked yesterday. I will see what happens tomorrow.


Hi @spockfish

All worked OK today, so I can confirm that the issue is resolved.