Album cover not added automatically

All new albums I add to my library don’t have an album cover.
What is really strange: Every time I update roon core, the album covers are added as they should, but it stops working after a few days

Also, roon Remote is showing “Adding music to library” is running continuously.
Also, roon Remote is showing Metadata Improver is “Paused”

This has been the case for some weeks (no hardware or software changes)

My Core machine: Intel NUC (i7, 16GB) running Arch Linux.
Roon version 1.8 (build850) stable

My collection contains albums from local hard drive, Tidal and Qobuz.
The album covers do not appear, when I add either a new album from hard drive, Tidal or Qobuz.

When I click “Edit → Identify Album → Save”, the correct album is found and the cover is shown, but this should work automatically.

I thought this was resolved (see Whatever is done during a roon core update. Please check with the developers and make sure to do it on every startup or fix this bug! Thanks

When you see the message metadata improver is paused it usually means your Roon Core is having difficulty connecting to Roon central.
Hence your music still works but the metadata becomes a little wonky as it is not being updated.

You can try exiting out of everything, stopping Roon server and rebooting everything and see if it comes back online for metadata

1 Like

I may agree with the previous speaker, as long as the metadata improver is paused, no new images, text or other enhancements are displayed and restarting with a 5 minute coffee break without power to the router is a good way to get fresh power to all devices.

Thank you both, but this does not solve my problem.
I poweroff and restart my roon core almost every day.

As I said. The Metadata Improver works fine for some days after any Roon Core update. But it then stops working and also doesn’t work after a reboot.

So there must be a way to “reset the metadata improver”. For me it feels like something in the update process is fixing the metadata improver. But of course I don’t want to wait until roon releases new updates, every time the metadata improver stops working for me… :slight_smile:

There is not really any way or function to “reset the metadata improver” unfortunately.

I have had this a few times and it has always been resolved by shutting down the Roon server and reboot of the unit the core is located on.

Hopefully @support will chime in, they will probably want to take a look at your logs.

Hey @Erik_Stach,

Could you please try to follow the steps listed here? We believe it should help.

We’ll keep an eye on this thread :nerd_face:

Thanks @Uwe_Albrecht and @AceRimmer for sharing your insights :pray:

@beka I already did all the steps in the provided link.
I am running the latest version of roon and use the cloudflare DNS.

It would be useful to know, which address the metadata improver has.
Then I could troubleshoot, if my roon core machine has trouble reaching the address.

But still, since every time after a roon update this issue disappears for some days, I am pretty sure this is a roon software issue.

Hey @Erik_Stach,

Thanks so much for making the time over this weekend to go through the steps listed in our article :pray: . I’m only sorry they didn’t work.

Would you be able to also share the details of your network setup? Router / Modem model and how are the devices in your audio system connected?

Are there any WiFi repeaters? Any VPN?

Hello @beka,
my Roon Core (running on an Intel NUC 11 Pro Kit - Intel i7-1185G7, Samsung 980 PRO SSD 1TB M.2 2280 PCIe 4.0 x4, Crucial 16GB DDR4-3200 CL22 SO-DIMM)
is connected via 3m Cat6 1GBit Ethernet cable
to a switch (Cisco Business CBS110-5T-D Unmanaged Switch 5 GE Ports)
which is connected to a Google Nest Wifi-Router via Ethernet Cable
which is connected to my router (FRITZ!Box 6591 Cable) via Ethernet cable.
In the router, I use the Cloudflare DNS server.
Before using Cloudflare, Roon was completely unusable, so I don’t want to switch it off again.

My internet speed is 500Mbps down and 40Mbps up.

Thanks for the quick reply! We think using Cloudfare’s DNS is a great practice :star_struck:

You mentioned having a FRITZ!Box. Could you please check if the feature below is disabled?

@beka this is fascinating. I turned off package acceleration on my Fritzbox. Then startet roon and added an album. The album cover was successfully added. However, the internet speed went down to 50mbps.
I then re-enabled package acceleration. My internet speed is up to 500mbps again.
Also, after adding an album to my collection, the album cover was automatically added.
I don’t see any “metadata improver paused” messages anymore as well.

I will keep an eye on this. The solution might really be to disable and re-enable the package accelerator.

To disable:

  1. Click on “Content” (Inhalt) in the bottom left corner of the fritzbox page.
  2. Click on “Fritz!Box Support” on the bottom of the overview.
  3. Scroll down to “Package Acceleration” (Paketbeschleunigung)
  4. Select “Package acceleration inactive” (Paketbeschleunigung inaktiv)
  5. Click on “Accept changes” (Einstellung übernehmen) on the right.
1 Like

That’s super to hear :partying_face:

Thank you so much for not hesitating to give that final setting a try :dancer:

Please, let us know if the issue reoccurs or if you have any other questions. It’s our pleasure to help out :nerd_face:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.