Album Editor - Metadata Preference - Prefer File not working on one album

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro (current update) / Intel Core i7-4770 @ 3.40 GHz 16 GB installed memory 64 bit OS, x64-baed processor / Data on external USB hard drives / Ethernet cable to PS Audio PSD II Bridge / Control on ASUS Android tablet / Work on files on PC / Roon build number: Version 1.6 Build 416 stable 64 bit.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Ethernet connection using Netgear Nighthawk R7000. Drives attached to PC, not Router.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

PS Audio PWD II, ethernet to Bridge. (Note: I am not aware of any hardware issues–everything works great!)

Description Of Issue

Classical multidisc set. Follow rules, all tracks on all discs have same album name, each disc in separate subdirectory to Album directory, each subdirectory named Disc01, Disc02, etc. Tracks in each subdirectory are 101_, 102_, then 201_, 202_, etc. 12,153 albums at this point, with few problems. In this album, Telemann-Tafelmusik-Concerto Amsterdam-Das Alte Werk Teldec:
Music is divided into separate 1-4 movement works, such as
Roon has these tracks as


No division into separate works or movement numbers. So, as I do, I go to
Album Editor - Metadata Preference - I mark Prefer File Save and it doesn’t change to my Filename (= Track Title) tag(s). I use the current version of MP3Tag to thoroughly tag all albums, discs, and tracks.

I am generally able to get tracks labelled as I want them. All files are [-Read Only]. What am I doing wrong? I would think marking Prefer File would trigger a simple copy&paste operation from Roon tag to Julius tag, unless some Roon database structural principle is violated.

Just beginning my second year, love this application!

Julius Moshinsky

As provided by the metadata provider:

So many options here that you can set to ‘Prefer File’.

If your files are tagged like this, you have to set ‘Multi-Part Composition Grouping’ to ‘Prefer File’ also to override AllMusic’s handling of the tracks as individual tracks (multi-part grouping off).

You should make sure that multi-part grouping is active for the album by checking on the ‘Edit Album’ page of the Album Editor (scroll all the way to the bottom) also.

Thank you, BlackJack!

Album Editor
Edit Album
Multi-part Composition Grouping
71 Tracks, 1 Performance UNCHECKED
Prefer File Data UNCHECKED (I don’t understand that–File Data shows up)
Disable Multi-Part Compositions on this Album UNCHECKED (I don’t understand that–nonetheless it works!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.