Album fails to start - HQPlayer

@jussi_laako I am using embedded 4.20.3 and playing to an naa 4.1.1. Both are on Antipodes EX. When selecting a new album to play the roon indicator shows playing but HQPlayer fails to initialize. Sometimes selecting a little further on in the time line starts it. Sometimes selecting a different album. This began for me in 4.20.2.

This behavior was fixed in 4.20.3, so I would double-check that you are running latest version from /about page of the web interface.


Actually, I upgraded to 4.20.3 and boom something like this is now happening to me. Sometimes, I start an album and the little dancing meter icon next to the track dances but the track never starts to play. It hasn’t happened in the last day or so but did happen with the first two albums I played right after the upgrade.

Hi Jussi. I did check just before posting. It is 4.20.3.

OK, I need to figure out how to reproduce such here… Otherwise it is hard to fix.

P.S. Could you try booting HQPlayer OS on the device and see if the same happens?

Unfortunately with the Antipodes that is not possible. I have tried re “Apply” (initialize) but not a positive fix. I’ll monitor it and see if it can reproduced.

I think Antipodes should be able to boot HQPlayer OS. This just helps indicating if it’s the particular HQPlayer build that is acting up or something overall in HQPlayer. HQPlayer OS makes things a little bit more straightforward as it’s one specific piece of software including entire OS.

Just installed 4.21.0 and after I paused a track and then clicked on play the track did not start.

There have been a couple of updates since 4.20.3

Your point?

Using 4.9.2 desktop which may have fixed it. I will have to wait on the latest embedded to be made available by Antipodes. There were sonic improvements with 4.9 desktop as well.

If you go to HQPlayer webpage see updates fixes with NAA in updates thats my point.

Hi @Outlaw. I am now using 4.21.1 . I feel there is an increase in sound quality with this release. This is the first time I felt that for embedded. Lovin it!

As of today I am now using 4.21.1 and have not experienced any failures to start albums playing.

I am not noticing any sound quality improvements. Why would there be? @jussi_laako, we’re any of the filters, oversamplers, or modulators improved?