Album images showing as grey in some views

Roon Core Machine

Roon Unraid docker container. 12th gen i3, 16GB

Networking Gear & Setup Details

Linksys Velop

Connected Audio Devices

Several Apple & Windows desktops, iOS, iPad OS devices

Number of Tracks in Library

30,000 tracks

Description of Issue

Added a new album to my library and in some views it is showing a grey box, but others it is not.

However, when I go into the album view:

You can see the album page is showing the correct image. The Roon preferred image is what is selected and is grey, but the album page is correct.

The exact same thing happens for me with Pearl Jam’s Ten as well. Most of my other albums are fine.

It is very weird. I’ve tried Settings → Setup → Clear Image Cache and it still happens and replicates across all my devices.

Hello @WWLAladdinSane ,

Thanks for the report here. Does the issue happen across multiple Roon Remotes or just on one specific Roon remote? If the issue happens on more remotes, is it always the same album that is blank?

It is all Roon Remotes - iOS, MacOS, Windows and it is the same album(s) that have the issue.

Another thing I was able to capture is that it does have the correct album art for a brief second.

I attached a video on both the Home Screen and album page where you can see that it has the right image but then flushes it.

https://www.dropbox.com/scl/fi/m3iw2sw6uf70z2iyptvvu/Roon-ScreenRecordings.zip?rlkey=8zw9ocl3u6fccxo28suuoaejv&dl=0

@noris - Any update on this? Did the videos help clarify the issue?

Did you clear cache on your remotes? Sometimes it does the trick.

Yep, that was my first guess. Did it on all my devices and still have the issue.

Still an issue after the newest version on all clients.

Hi @WWLAladdinSane ,

Apologies for the delayed response here. Can you please let me know the exact local time + date when you next observe this issue? I’d like to enable diagnostics mode for your account after receiving these details to see if there are any errors associated at the time of the issue.

Have you tried to temporarily host the Roon Server on any of these PCs to rule out the docker container as being a factor? Do the same images cause issues across multiple systems?

No worries, not the biggest issue in the backlog, I’m sure :laughing:. I just changed the images back to the Roon/Preferred version that cause the issue. Reopened my Mac OS client and encountered the issue (4 Jan 7:24-7:28a CT). You can see it here:

I have not tried to rehost the Roon Server. If the diagnostics don’t help let me know, send me directions and I’ll give it a try.

Thanks!

Funny, each question you were asked you had already provided that information in your first post. Comprehension and reading skills appear to be lacking :man_shrugging:t2:

Maybe? I don’t think that is fair, Noris has been great. I’ve worked in tech support in my past life and it is hard and thankless work trying to figure out what people are doing.

1 Like

Still having this issue on Roon 2.0 build 1359.

I’m having the same issue. It only started about a week or two ago. Lots of greyed out album covers when scrolling through albums but the album cover is there if I click on the album. I’m using a Roon Nucleus+ and an iPad Pro as a remote.


Hi @WWLAladdinSane ,

Thanks for letting me know that the issue is still ongoing, I’ve activated diagnostics for your Roon Server and I can confirm that a log set reached our servers for review. Looking over the image errors present in the log set, I believe these errors may be related to the issues you are experiencing:

01/19 07:54:13 Trace: GetImageData[Remote](id=60962 spec=16by7_2048 key=semdaaaa uri=https://imagecache.roonlabs.net/im/1/artists/7a004d4e30303031363037343236/photo/16by7_2048.jpg) => fetched in 178ms status=200 size=69430 overalltime=213ms
01/19 07:54:13 Trace: GetImageData[Remote](id=60962 spec=16by7_2048 key=semdaaaa uri=https://imagecache.roonlabs.net/im/1/artists/7a004d4e30303031363037343236/photo/16by7_2048.jpg) => fetched in 190ms status=200 size=69430 overalltime=217ms
01/19 07:54:13 Warn: [broker/httpserver] While Serving Image: The process cannot access the file '/data/RoonServer/Cache/images/se/md/semdaaaa.16by7_2048.jpg' because it is being used by another process.

&

01/27 18:23:03 Trace: GetImageData[Remote](id=12810 spec=1024 key=sysaaaaa uri=https://imagecache.roonlabs.net/im/1/albums/3e019926f65344629b49ad7c2aa0f3ac8086/cover/1024.jpg) => fetched in 655ms status=200 size=68385 overalltime=695ms
01/27 18:23:03 Trace: GetImageData[Remote](id=12810 spec=1024 key=sysaaaaa uri=https://imagecache.roonlabs.net/im/1/albums/3e019926f65344629b49ad7c2aa0f3ac8086/cover/1024.jpg) => fetched in 514ms status=200 size=68385 overalltime=562ms
01/27 18:23:03 Warn: [broker/httpserver] While Serving Image: The process cannot access the file '/data/RoonServer/Cache/images/sy/sa/sysaaaaa.1024.jpg' because it is being used by another process.
01/27 18:23:03 Debug: [easyhttp] [2951] GET to http://127.0.0.1:9330/image/sysaaaaa.1024.jpg returned after 563 ms, status code: 500
01/27 18:23:03 Warn: [broker/images] while downloading image: got HTTP 500
01/27 18:23:03 Trace: [roonapi] [apiclient 192.168.1.20:49439] COMPLETE NetworkError

Can you confirm that these images are part of the affected images that you were seeing disappear on your end? Is there anything else that could be trying to access these images at the same time as Roon, such as rsync or such?

Are you able to temporarily host the RoonServer database on one of these PCs, restore the database, and see if the issue reproduces on another OS? I suspect something about the docker setup might be causing multiple files to try to be accessed simultaneously. To switch Servers to the PC:

  • Create a Backup of your current database
  • Open Roon on the other PC you wish to try running as your Roon Server
  • Roon Settings → General
  • Disconnect
  • On the “Choose your Roon Server” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Server at a time but you are free to switch between them as often as you’d like
  • Restore the backup from main database
  • Verify if the same behavior occurs on the different PC Server

Hey @noris,

Thanks for the reply. The top image is familiar, the bottom is not. The album linked to the top image is not having any issues.

I don’t have any rsync/rclone or anything accessing the docker. I do have a cron job that closes it and restarts it every night and another job that closes it, performs a backup of the docker image and turns it back on. Those are the only things I can think of.

I’m trying to restore from my backup. I copied my dedicated Roon backup share, which is (10.53 GB on disk) for 63,805 items. I’m using the latest MacOS client. I point the restore to the directory and get this screen:

I’ve chosen a few different ones and each time it is only loading 3 tracks:

.

Any ideas?

I deleted all the backups, created a new one (that was much smaller) and did the above again. Still no tracks.

I pointed to my music share and it started to rebuild the library. I’ll need to try this on another computer to see if that resolves it, it wants to rescan all 30k tracks so it will take hours. I’ll give this another try later.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.