Album missing from roon exists in directory tree [Resolved]

I have rock on a NUC. I discovered that an album is missing. It is in the directory structure. After reading some of the threads on missing albums, I checked the skipped files. There aren’t any. I then did a force rescan. The album was still missing.

I then reripped the album using different software and put it in a different directory tree. It was still missing. I then did another force rescan. It is still missing. I realize it could have magical characters that Roon doesn’t like, but I don’t see any in the file names or directory names.

I have two questions: how do I get Roon to see the album, and how I do I find out how many other albums are missing?


Hi Robert,

What format did you rip the CD? Also, can you try searching for a track in Roon? Maybe the album is under Various Artists or something.

Cheers, Greg

If you go into Roon’s tracks browser, add the file path option to the visible columns and sort by it.

If that missing album has be imported into Roon you should be able to find it and check its identity via the path.

Also if done at the time of import… I find using Roon’s Album browser, ordered by date added very useful to track down missing album.

Some other ideas here @Robert_Lesser:’t_showing_up_in_Roon

The answers to the questions asked above:

I ripped it into flac, both times.
I looked at the path option and the album and files are not there.
I looked at albums sorted by date add, it is not there.
I looked at the missing files page and it had no useful information.

Again, @support, where is my missing album and how do I find out how many other albums are missing?

Any change if you go into Settings > General and enable “Show Hidden Tracks And Albums” ?

I would check for special characters in file names as covered in the link @mike provided. Can confirm I ran into this.’t_showing_up_in_Roon

I turned on show hidden tracks and albums. The missing album is still missing. When I searched for a track on the missing album, it did not appear.

I still do not see any special characters in the file names or the directory.

Any other ideas?

Hi Robert,

Can you post a screenshot of your Storage Settings in Roon. Also, a shot of your folder showing the album. What computer are you using to access your ROCK storage folder?

Cheers, Greg

Sure, the screenshots are attached. I am not sure how that will answer the question of the missing album.

Have you tried removing the comma after “Spree”? Make sure you remove all such characters from all files in the album.

Just did that. No change. Why would removing a comma matter? It is not one of disallowed magical characters.

Hey @Robert_Lesser – do you have access to Dropbox? If you can zip up the album and PM me a link, we can try importing it here.

That way, we’ll at least know for sure whether this is related to the files themselves, or something about your environment or setup.

If you don’t have Dropbox, that’s fine too – just zip up the album and send me a PM. I can give you a way to upload the album directly to our server.

Thanks for your patience on this!

OK. I can do that. How do we PM?

I just sent you a PM – you can find your inbox by clicking the envelope under your avatar, in the top-right:


1 Like

I put the zip file in the folder. I tried to do this this morning, but I kept getting a 502 bad gateway for the support page.

Try again – we had some server issues this morning, now resolved.

Bad timing :wink:

just to be clear. I put the zip file in your file uploads thing.

Hi @Robert_Lesser ----- Confirming that the media has been received and downloaded. Once our techs complete their analysis I will be sure to share their thoughts/findings with you in a timely manor.

Your patience is appreciated!

Hi @Robert_Lesser ----- Thank you again fr your patience while our team has been evaluating the provided media.

To bring you up to speed we were able to reproduce this behavior in house and one our techs noticed that when the content was imported into Roon (under ROCK) the files were landing in “skipped files” due to an IO error.

However, upon closer investigation the team noted that there was a “character” added to the end of the folder name that was only presenting itself when used in a Linux based environment (see below). Renaming the folder allowed the content to be imported successfully without issue.

13 PM