Album not playing in Roon but playing in Qobuz app

The late Bunny Wailer’s Protest

won’t play through Roon but plays through the Qobuz app

I’m on Qobuz USA although am located in Ireland.
Could someone else check if this is just an issue for me?



Seems like network problem. Unplug everything and restart all devices. If this doesn’t work ask further in the support section.

Thanks but Qobuz plays all other albums fine and this plays on Tidal fine, so I don’t think it’s a network issue.


Works okay for me in UK. Have you added it to your Roon Library? If not, it’s worth trying that. If it’s already in your library, delete it and then add it via the Qobuz app as a favourite. Not sure why but this worked for me on a single album displaying the same error message as you’re getting.

If none of those things work, I’m out of ideas!!!

1 Like

Roon 1.8 is very demanding on your network. Had same issue and fixed it the way I mentioned.

1 Like

I’ve tried all these, even cleaning my library.

So it’s in my Qobuz favourites in Qpbuz and plays.

but doesn’t show up in Roon (I have synced).

@support any ideas?


Plays normal here. (Holland) Imported from Qobuz

Go to services -Qobuz- sync now

Thanks I have tried that.


Sorry out of options🤔

1 Like

@Sloop_John_B - you’ll likely have tried this but I find disable/enable the Qobuz service sometimes fixes oddities.

From the services screen - Edit >> Disable (top right)
Give it 20 seconds then enable

1 Like

I have occasionally found that the actual album in my library is no longer available, even though it SEEMS like it is.

Different recordings have different IDs within Tidal/Qobuz. So when you go to the service to play the same album, the album you’re playing might not be the exact same one that’s in your library. Might be a different mastering or reissue or whatever. (This happened to me with some Sade album a couple weeks ago.)

So, try this (it worked for me): delete the album from your library, and then find it again on Qobuz and re-add to your library.


I live here in the US. I have same problem with streaming from Qobuz. I can’t even browse qobuz through Roon.
Streaming free radio stations works fine.

update. Rebooted my router. Everything is OK

1 Like

I had the same problem and rebooting Router helps, my Router is enterprise grade /strong network protection / maybe to strong :slight_smile: