Album not showing all tracks

Dell I7 Precision, 16 Gb 64 bit Windows 10
ROON version 1.6, build 416

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
PC on a “flat” network, Dell gig switch, Buffalo 4 tb NAS with 4 drives. Wired gig ethernet. Core and playback are on the same PC

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Focusrite Scarlett 2I2 series II USB connected to the core PC

Description Of Issue

I have Roon use a library made by JRiver Media center. I have and issue with an album that originally showed up as two albums in Roon. I deleted both and now when Roon re-indexes only one album and one track shows up. The only non ascii characters in the track file names are apostrophes and commas.
I have deleted the album and replaced the directory with the same result. I have forced a rescan multiple times as well.

Now I see three identical albums show up! Two just have one song… the same one! The other has the remainder.

Hi @Jeffrey_Weissert,

Can you share screenshots of what you’re seeing in Roon as well as screenshots of this particular album in its storage location?

Here are four screen shots.
One with the main Roon screen showing the three albums
One showing the track detail but missing one song
One showing one of two identical details of the album with the missing/rouge song
One showing a explorer view of the source library file folder


Wow… I finally found the “merge” command… never thought that it would be on the main screen!
Now my next issue is on another album… only one track shows up… I have deleted it… replaced it… etc…
Forced a scan… no luck

Ok…finally found the pieces and merged them… long day… stiff neck!

Hi @Jeffrey_Weissert,

For the second example you shared above, the Franz Liszt album, would you mind sharing that media with us so we can take a closer look at why it didn’t import correctly initially?

Ideally, you can zip up the entire folder and send me a private message containing a shared dropbox link. If you don’t have Dropbox or need another way to send the media, just let me know.

Well the Franz Liszt album is fixed but the first on “Bobby Bland” which was fixed with the “merge” has reverted to its display of three albums after opening Roon this morning… all was well yesterday! Where can I share a link to that zip of the directory? Also the Liszt is one of those “cheap” CD’s not an original release of note… I can see why any auto/database would get confused

Hi @Jeffrey_Weissert,

You can send me a shared Dropbox link (or a link from another file sharing service) in a Private Message here on the site. If you click my profile image and navigate to my profile you should see this option.

I clicked on your image and only got these options… tried merging again… maybe it will stay put this time!

Hi @Jeffrey_Weissert,

I’ve updated the permissions on your account here on the Community site. If you see this issue return after the merge you should see the option now for the Private Message so you can send the file.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.