Album pictures gone black (Roon 1.8 build 923)

Roon Core Machine

Intel NUC 7i7
Intel i7 7th gen

Networking Gear & Setup Details

Switch HP1920S

Connected Audio Devices

Allo DigiOne running RoPieee coax. digital link to DAC

Number of Tracks in Library

650 Albums, 11000 tracks

Description of Issue

After updating to Build 923 all the album picture are black, only in my Windows 10 PC (with ATI FirePro V3700 (FireGL). On my macOS laptop there is no issue.

Have you rebooted the Win10 PC since the update at all?
If not might be worth trying.

Yes, I have rebooted both: The PC and the Intel NUC (Core).

On the macOS laptop everything seems OK. On the iPad Pro also seems working fine.

I just noticed that on the Windows PC, from time to time a row of pictures can be seen, but the others are black. Besides, when I scroll, there are short glimpses where I can see the picture then goes black again.

Really weird.

Yes it’s most odd.
I have two win10 PC running and not seeing this on either PC.

1 Like

It must be a problem that is specific to my PC.

I have cleared the image cache and restarted Roon on the PC, and the PC itself later. The problem remains the same.

Curiously, some albums (very few) are properly shown.

Try disabling the wi dows firewall as a test.

1 Like

Thanks @ged_hickman1, but it’s very unlikely that this is a firewall problem. There has been no previous changes on the firewall and Roon worked fine until the last update. Besides, some of the pictures are shown.

Roon works, except for the images and this is annoying.

Have you checked if the drivers are up to date for your graphics card? I’m not a PC user, but I’ve seen quite a few threads where quirky display issues were resolved by an update.

1 Like

Hi @DaveN , the graphic card is old, so the drivers are old too. Updated to the more recent version, but old. They are the same drivers that worked properly until the last update. Besides, remember that a few pics are able to be shown.

Sorry that didn’t help. Hopefully support will be able to offer some more useful advice.

1 Like

Thanks anyway, @DaveN. I appreciate it very much.

Months ago, after an update, I had problems with this very graphic card. The text was not shown, but the Roon guys fixed it a few weeks after.

Roon staff will know if there is any change in the current version that can cause this isue with an old ATI card.

1 Like

Any ideas from #support team?

It is annoying watching the screen full of black patches :frowning_face:

Hello acatala. I am new to Roon and the latest update has affected me the exact same way (and my computer is exaclty as yours [old but up to date drivers]. My Roon is powered on a separate Nuc Core, but my Windows is showing (most all) album images as black. Were you able to resolve your issue with Roon Support ?. And yes, the blacked out images are very annoying.

1 Like

I had a similar problem with the last couple of releases. Finally seems to be solved here by changing the DNS on my NUC to Tried my provider DNS, Google DNS, all were giving me blanks on my artwork. Reboot of NUC with the other DNS entries and everything was fine for about 24 hours then the artwork would start disappearing again. After swapping to seems to be fine so far… fingers crossed. Could be worth a try.

1 Like

No, @Doug_Ford , my issue is still here with me.

Thanks for your piece of advice, @John_Steer1 . But my DNS is local to my network. The forwarders defined for my DNS server are Google DNS. I can’t make changes on my DNS server.

Besides, Roon should work with Google DNS as used to do until now. The Intel NUC where the core runs, uses my local DNS server. It has been working flawlessly, in fact, Roon still works on my macOS computer without black patches.

Damn, it didn’t last here either. Back to gray squares. Mine works with a reboot but after a day they randomly start to disappear again. :frowning: Obviously something keeps failing on the ROCK Intel NUC.

1 Like

My Roon Core runs on an Intel NUC on Debian, not ROCK. I don’t know where the problem is, but I would bet it is not on the NUC part.

I use Roon most of the time from my PC, the one that is currently having the issue, but Roon works fine on my macOS, my iPad and my iPhone. That’s why I think the problem is in the client part, my Windows client.

We’ll see.

If you turn off your firewall as a test, do the album images appear?

No, they don’t :worried: