Album Rescans Don't Seem to Work Anymore

Running Roon Server 1.7 build 667 on Mac Mini (OSX 10.14.6); Roon end-nodes (Macs 10.14.6 and 10.15.7)

I used MetaDatics to correct song names (basically removed extra info like “recorded live…”). I can see the song names are now correct. I go into Roon and try “Rescan Album” but the new names are not picked up. I tried going into Settings->Storage and did a Force Rescan of the library, that did not work. I then stopped and restarted Roon Server and that did not work. The songs still have the old names. I have triple checked the data in the files via MetaDatics and can see the new names are indeed saved in the files.

This is a practice I have done many times as a number of my live recordings have extra information at the end of the song name. I have successfully many times over been able to use Metadatics to correct the names and rescan the album for Roon to pick it up.

Note that Roon is able to play the album without any problems, but is still displaying the old song name.

Any ideas?

I am assuming you told Roon to use your meta-data for those albums. Maybe a Core reboot?

Hi @rayski,

How do you have your Roon Settings -> Library -> Import Settings configured?
Are you using prefer Roon or prefer file?

Sorry I’ve been slow to respond, but some personal stuff here at home that soaked up all my time.

@noris It’s a bit of a mix bag, but mostly “Prefer Roon” including ‘Title’. Interesting enough, just checked today and all the song titles have been updated as per my edits via Metadatics. So Roon did pick them up but yet the Forced Rescans of Album and Library Folders seems to not be picking up the file changes. Though if I add a new Album and do a Library Folder Forced Rescan it will register the new album immediately.

In summary a bit of a mix. Roon fixed it over time (good), the Forced Rescans don’t seem to be working at the song file level (not good).

1 Like

Hi @rayski,

Thanks for testing this further, can you please confirm if restarting Roon Server also allows the edits to be picked up?

When it wasn’t picking up the changes, one of the things I tried was restarting the Roon Server software running on my dedicated Mac Mini (late 2014, running OSX 10.14.6). That did not help at the time. It seems the only thing that helped was patience of a couple of days. Note that my Mac Mini running Roon Server never shuts down or is the Roon software stopped. It just runs forever. However in this instance I did try the restart.

Hi @rayski,

Thanks for checking the reboot behavior. Where was the media stored? On a NAS or locally attached HDD? Does the issue only happen when you use MetaDatics or does it occur with other metadata apps?

@noris I have a Synology NAS that store only my music files. An Apple Mac Mini (late 2014) that ONLY runs Roon Server. The rest of my environment is MAC laptops and iPads.

Does the issue only happen when I use MetaDatics? I always use metadatics. I have a huge grateful dead collection that requires me editing the music files with every concert I acquire. Need to add concert details, song meta data, etc. Every one of these requires editing. In general they work when I edit them correctly the first time. However, if once edited and loaded I find an error that requires me going back to re-edit then I find issues with Roon picking up the changes. Most times over time Roon will catch up with the changes. Rarely will a re-scan (song or album) will work, just time.

1 Like

Hi @rayski,

If you notice the issue re-occur, can you please let me know the edit you made and the exact local time + date + track the change didn’t show up in Roon after a rescan?

will do. Might be a while though.

1 Like