Album search always matches to Qobuz and ignores local files

Since adding Qobuz to Roon I’ve found a irritating behavior in Roon.
In Roon, I’ll go to ALBUMS and in the search box enter a name of the album. 90% of the time Roon matches to a Qobuz hosted album and fails to show my local shared albums in the Roon database.

I would rather play my own files and reduce my internet usage (Comcast cap).

Is there a way to get Roon to default to local files/albums first when searching?

Yes, in the focus section you would scroll until you see storage options and just highlight local storage.

1 Like

Thanks for the suggestion.
But, it doesn’t seem to work.
I added my local music folder (archaically named MP3 - that’s how old it is)
But when in the My Albums section I enter an album name in the search box and it still defaults to Qobuz (even when the Qobuz album is not part of my library).


Notice the Qobuz logo in the corner. What am I doing wrong?

Roon’s search is not meant as a way to inspect ones library. It’s meant to find available (high quality) music to listen to and that is related to the search term.

What you want is to use the Filter function. On the album page, for example, it is on the right side opposite focus. This will filter your library and only your library.


Thanks Rugby, That actually works very well.

1 Like