Album version not displayed for DSF files

I have Roon 1.3 configured to “extract album version from album title” during import. This used to work perfectly with the version displayed in the browser. Version is being displayed presently for AIFF files but not for DSF files.

The problem can be seen in the attached image as the far right album was given the title “Close to the Edge (SACD)”, so SACD should have been listed under DSD64. Note that the other albums - which are all AIFF files - display the version properly.

This appears to be a bug recently introduced - maybe in 1.3. I’m presently running build 207 on my iPad and build 208 Core on my Mac Mini. The problem is evident both on iOS and MacOS browsers.

it is working here (Roon 1.3 build 208, macOS 10.12.3)
first row, second album: both “Montanari” and “DSD-64” are in folder’s name (in brackets and square brackets)

… on my iPad too (Roon 1.3 build 207, iOS 10.2.1):


I’m glad to see that it’s working for you. I wonder if the difference comes down to you using brackets while I’m using parentheses. Both options are set to yes for me in my import settings.

I have over a terabyte of DSD rips so no way that I’m going to go back and revise all the album names and change all parenthesis to brackets.

This used to work fine for me with DSF files - just as it does now with AIFF files. There’s been a change in Roon functionality.

Another way to go is to add a VERSION tag to the files. I found a way to do this with Yate and it works!

I’m still hoping though that there’s a fix to Roon that allows it to again use the parentheses in the titles of albums in DSF.

Version Display for DSD [and indeed All] albums still works as before…as you can see in the screenshot, which has DSD albums displayed only…see the Versions displayed for many

What you’re seeing is that Roon won’t display the Version when the Version matches the Format…e.g. when the User just puts 24/96 inside the square brackets or regular brackets for a 24/96 album

For just one of your DSD Albums, use File Manager or Finder…and change the information within the brackets to e.g. SACD 2017…and you will see that Roon will pick it up and display it…you may need to rescan if your library is on a NAS

The album titles end with “(SACD)”. So the version should be SACD while the format is DSD64.

The DSF files themselves have had the album title tag written to them. That was done with tagging software as this is not something that can be changed with Finder.

I have hundreds of ripped SACDs that I tagged over several years. I don’t want to change each one manually, Roon used to handle my naming method perfectly.

I hope @support weighs in as this seems like a bug.

Check you import setting are ON for curly bracket.

My import settings were set exactly as in your screen shot,

Solved! A friend who didn’t have this problem shared his import settings. “Extract album version from album title” was checked in his settings but not mine. I assumed that since version was display for PCM files that my settings were fine. For those files, I’m guessing it pulled the version from the path (folder name).

Isn’t that what ncpl posted in his screenshot??

Yes both he and I had the same setting for Extract album version from file path. We both had it set to No. Switching that to Yes fixed the problem for me (though I had to force a rescan to reimport these).

So, let’s just clarify to close this out…for future search reaults.

Your album [version] is in the folder path and not your album meta tag ?

If that is so then indeed you would need to activate the “version from file path” option.

I’m apologize - I’m doing a terrible job of reading and communicating. It was the “extract album version from album title” that was set to no in my case. That needed to be set to Yes in order for Roon to extract the version from the album title that was tagged to my DSF files.

Very sorry for the confusion.