Albums on Tidal only available through browser

I’ve not been able to bring up any music through Roon’s Tidal client, though I can pull them up through the browser. I’m logged in to the same account, but for some reason every track I’ve tried shows as “unavailable”, though the same tracks play fine in the tidal browser. Anything I should try?

Hi Tyler,

Are you still having issues with Tidal?

If so, can you try shutting down Roon or Roon Server (whichever you’re using) on your Core machine and then restart the app?

See if that helps.

Cheers, Greg

Hey Greg, thanks for the tip.

I restarted everything, rebooted both the core machine and the client, and I’m having the same issue. Both on the core machine and the client, I can play tracks through a browser, but not through Roon.

I’m located in Turkey, which I suspect might be causing the issue, though my Tidal account is linked to a U.S. bank account, and I’m paying for my subscription in USD.

Hi Tyler,

Being in Turkey could definitely be the problem.

We should get @mike to help.

Cheers, Greg

@Tyler_Beebout — we would like to check your Roon logs. I’ll contact you guys via PM with detailed instructions. Stay tuned.


I would like this to be fixed by Roon. I can play all Prince albums on the Tidal website. I can play NO Prince albums via Roon. There are other albums, such as Siwan (Jon Hassell) that show up in Roon and have a full Roon review, and can’t be streamed and aren’t available in Tidal Why do they even show up? I live in the USA. This has been going on for a long while. Yes, I deleted my cache. I thought after spending $500 USA for Roon access , I would have a full pass to my $20 a month Tidal subscription to play what they offer through Roon. But the Roon/Tidal connection is broken in many places, and I would really like it to work. I like Roon. I would like my Tidal account to work within Roon. Thanks.

The thing with ECM titles appearing and not being available is very frustrating. This is a Tidal issue not Roon. See this discussion here.

i hope someone else can help with the Prince problem. That should not be happening.

I had a Tidal problem suddenly cropped and a re-boot fixed it. Thanks for the reminder.