Albums Unplayable after Restoring Backup

(Kinlin Chu) #1

Added Nucleus + to enhance my ROON system performance recently.

My Roon setup:

  1. Nucleus+, dCS network bridge (connecting to my Wadia 931/922 decoding computer), Synology DS1817+. All devices connected to local network.
  2. All devices installed latest Roon core/client (1.6, build 416).

My Problems:

  1. Got connection trouble while adding music folders in settings tab “Storage”.
    And the trouble fixed after changing the password (with letters and numbers only, w/o any special characters).
    Roon will not recognize any NAS shared folder if NAS password contains special characters.)

  2. Found that new importing is too slow.
    What should I do to avoid a fully new importing?
    New importing is too slow since my music collections got more than 12,000 albums.

I tried to restore previous back-up, after restoration with backup file from a few days ago, then noticed that Roon did quick rescan for one of the folders, but finally found that all previously imported albums are unplayable.
Tried playback with many albums, always got orange error message says “Playback was interrupted because a track failed to load.” and “Too many failures. Stopping playback.”
Is it because I changed the NAS password?
Seems each single file need the new password for accessing?

  1. Somehow the other huge folder not got the “quick rescan”.
    And seems fully new importing being performed. And the newly added albums are normal and playable.

  2. If unfortunately the above backup restoration failed, then new importing is needed.
    Will those previously created tags/playlists be missing or also unplayable?
    This is my another concern, creating a lot of tags/playlists really need much efforts. Thanks for support!

(Dylan Caudill) #3

Hi @Kinlin_Chu,

So just to confirm the steps here, you did the following:

  1. Changed the NAS password
  2. Updated this in Roon
  3. Restored a backup
  4. Noticed that some albums aren’t playing
  5. Noticed that some albums are being imported newly

Is that correct?

Can you share a screenshot of the following:

  • Settings | Storage
  • Settings | Library | Clean Up Library
    • Note that you don’t want to run this process, I just want to see a screenshot of the window

Can you provide some additional details of your network setup?

  • What router is in use?
  • Is there any other networking gear in use (switches, access points, etc.)?
  • How are your devices (Nucleus and NAS) connected to the network?
(Kinlin Chu) #4

Hi, Dylan,
Yes, that’s correct for the steps I did.
Here is more detailed steps:

  1. Changed the NAS password
  2. Updated this in Roon
  3. Restored a backup (the backup file was created while Roon core installed in NAS). And now tried to restore the backup file into my newly added Nucleus.
  4. Noticed that some albums aren’t playing
  5. Noticed that some albums are being imported newly

Screen shots as below. Actually I did run the clean up library after found so many albums unplayable. Now all items shows 0 there.

And below are some more information you requested.

  1. My router is Linksys WRT3200ACM.
  2. No any other switches, access points in use.
  3. All my network audio devices (NAS, Nucleus, dCS NB) connected to the router.
(Kinlin Chu) #5

Hi, @dylan,
Here is my latest finding.
I tried to delete one of those unplayable albums, got a error message says “File not found.” Seems Roon lost the correct file path or something else. See below snapshot.

(Dylan Caudill) #6

Hi @Kinlin_Chu,

If you look in Settings | Library | Skipped Files do you see any of those files there?

Can you share a screenshot of this album in it’s storage location so we can see the file path?

(Kinlin Chu) #7

Hi, @dylan,

To make things simpler, I made a new backup file under original Roon Core installed in my NAS. It works perfect now in that Roon core.

Then I tried to restore the new backup file into Nucleus+ core.
Then nothing showed in library. Check the storage page, found below error message. “This drive is not available.”

The same page with Roon core in my NAS as below.

Now the question is does Roon support library migration from one Core to another?
If yes, then what should I do to fix the problem?

The library maintenance page shows as below now.

(Kinlin Chu) #8

Sorry, now no any “Skipped Files” now while look in that item since I just restored a newly created backup file from the Roon core in my NAS.

(Kinlin Chu) #9

Hello, @dylan,
Seems part of the problem fixed after adding the two folders manually.
Old password used this time during adding the folders.
It’s very weird that the NAS password has been changed (I am quite sure for this) due to the “special character” bug of Roon, but the old password did worked here.
But new password also worked if I delete one of the folder and re-add again.
Just found any password can be used to add the folder now.

Now all albums from 1st folder are normal (playable) after Roon’s automatic quick rescan.
But the 2nd folder still need a full new importing, without the quick re-scan for those albums migrated via previous restoration. See snapshot below.

Is it a new bug? I am not sure.
Obviously, the folder paths are very different. The worked folder path is simpler.
And the problematic path with the red error message was there right after the restoration.

(Dylan Caudill) #10

Hi @Kinlin_Chu,

Thanks for the updated info here. So, just to verify, after doing the above things are now working for you? Can you share another screenshot of Settings | Library | Clean Up Library?

Are all of your current play counts and edits in place?

(Kinlin Chu) #11

Hi, @dylan,
Unfortunately only one of the folder were successfully restored.
As you can see from the screen shot, the 2nd folder are being newly imported (only 139 files imported at that moment.

Screenshot as below.
Actually I made library cleanup one time already after adding the folders manually.

The problem is how to fix it? A total new importing is really annoying and time-wasting.
It’s been a bad experience with the newly added Nucleus+.

What is current status of the password “Special character” bug?
Has it been addressed to development team for improvement for future Roon builds?
Does the password “special character” bug has any correlation to the restoration failure?

(Dylan Caudill) #12

Hi @Kinlin_Chu,

To fix this, I think the best option is going to be to restore a backup from before these changes were made. Do you have a backup from prior to these changes being made?

Once you’ve done this, if you need to change your watched folders, the best option is to edit the existing watched folders, not add new ones.

I can’t provide any specific timeframes here, but I have confirmed that, in our internal tracker, there is still a ticket open with our development team. We’ll be sure to keep you updated when more information is available.

(Kinlin Chu) #13

Hi, Dylan,
Thanks for the quick response!
Yes, the original restoration used the old backup file before all these changes made. But it failed, one folder lost connection with music files (unplayable), and the other folder lost all albums and triggered a new import.

That’s why I am here to seek help.
Guess all these failures caused by the “special character” bug.
Folders can only be added while NAS password does not contain special character. Then the failures/abnormalities occurred.

So it is still an unknown issue here.

(Dylan Caudill) #14

Hi @Kinlin_Chu,

Thanks for the clarification there. I think that, for the next steps here, let’s try the following:

  1. Create another backup in Roon
  2. Power off the NAS where the music is currently stored
  3. Restore the original backup in Roon
  4. Navigate to Settings | Storage and remove any of the watched folders
  5. When you check Settings | Library | Clean Up Library you should see all of your files counted here. Don’t run this process.
  6. Add the watched folders back in Roon. Roon will then match up the files on the drive with the files that exist in your database so they’re not imported newly.

Thanks,
Dylan

(Kinlin Chu) #15

Thanks Dylan!
Two more days later, the new importing should have finished.
Will keep the instructions for future use.

So your suggestion is for migration between different Roon cores, right?

(Dylan Caudill) #16

Hi @Kinlin_Chu,

Yes, when migrating between Cores, it’s best to follow this guide in our KB.

(Kinlin Chu) #17

Dylan,
Thanks a lot for your support!

(system) closed #18

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.