All artwork missing

Roon Core Machine

Macbook M1 Pro 32GB Ram

Number of Tracks in Library

21000 tracks

Description of Issue

Roon core. All album and artist artwork is not showing. I have most of my content in Qobuz, but the artwork is missing even for local albums. Some of the icons from the zone selection are missing, too. This occurred about 3 weeks ago after a version update.

I have tried:

  • clearing image cache
  • logging in and out of qobuz
  • logging in and out of roon
  • creating a backup and restoring from backup
  • reinstalling roon

Screen Shot 2022-01-11 at 12.34.01 PM

The images might be being blocked by something. Try turning off firewall/AV as first test. Then look at your DNS settings and see if you can set you DNS to or on the router, as that might help things as well.

1 Like

Thanks for your response. I disabled firewall and also changed router DNS to but it made no difference.

1 Like

It’s worth noting that all artwork does appear on the Room Remote Android app.

@Rugby Do you have any more suggestions about how to fix this? It makes the Roon desktop app mostly unusable for browsing.

Hey @Zac_Horn,

Thanks for letting us know and sorry about the trouble… :pensive:

While @Rugby is a wonder on community, he is a volunteer moderator and not Roon support. However, the steps he suggested are exactly what we would have suggested as well. A big thank you, @Rugby.

I wonder if you have tried to Clean up library? This function is in Settings → Library (Library Maintenance).

Thanks :pray:

Hi @beka, thanks for the reply! I just tried Clean up library, but unfortunately it made no difference.

I only now realize that you mentioned trying this step in your initial post :woman_facepalming: . Apologies.

Would you please try one more thing?

  • Exit out of Roon
  • Find and open your Roon database
  • Navigate to /Library/Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Thanks :pray:

A post was split to a new topic: Artwork missing, even for local files

An interesting thing happened to me… a few days ago about 1/4 of the artwork appeared without me doing anything at all except restarting Roon core. I optimistically waited a couple days for more artwork to trickle in, but none did.

@beka’s Next I tried your instruction to move the Roon cache away from ~/Library/Roon/Cache and restart. Unfortunately, this caused me to lose all the artwork. Restoring the cache to the original location and restarting did not help, so I’m back to all artwork missing.

Hey @Zac_Horn,

Clearly not the outcome I was hoping for — I am so sorry for the way things have turned out. Would you please, just for good measure, grab a set of logs, zip up the entire folder and upload them to our drive?

I’ve taken your case to our technical team and the logs might really help them narrow this down.

I’m sorry we won’t be replying over the weekend — we’re returning to work on Monday.

Hi @beka,
Thanks for escalating my problem to the technical team. I’ve just uploaded my logs, let me know if there is anything else I can do to help debug.

1 Like

Thanks @Zac_Horn. I appreciate your help :pray:

The logs are now with our technical team. I’ll follow up as soon as I hear back.

Hello Zac
Has this been resolved for you? I have the same issue.

On Friday all artwork was appearing and worked well for the whole night. I checked just now and all artwork is missing once again.

Some more strange behavior- when I scroll through my collection it appears the artwork is there for a fraction of a second on some albums, but quickly turns to a gray square.

No changes have been made on my end other than restarting the core, and I believe updating to the new version sometime last week.

1 Like

Thanks for the update, @Zac_Horn :pray:

Please, allow me to circle back with our technical team. I’ll follow up as soon as I can :nerd_face:

Hello, I’ve the same problem since yesterday

Hey @Zac_Horn,

Thanks so much for your patience :pray: .

Our technical team has taken a look at the logs you’ve shared and connectivity issues are apparent.

Could you please check if Private Relay is turned on, and turn it off instead (on your Mac)?

Also, do you have more than one multiple network interface active (WiFi and Ethernet)?

Hi @beka, no worries I understand these issues can be problematic to diagnose. I’ve confirmed that Private Relay is off and and I am only using WiFi network interface

1 Like

Appreciate the quick reply :pray:

I wonder, would you be able to try these steps?

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page
  • Restore the just created backup

If you can perform these steps, would you please let us know if it helped?