All Audio Devices Disappeared

Core Machine (Operating system/System info/Roon build number)

MacOS 10.12.6 / Headless Mac Mini / Roon 1.8 (Build 764)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Eero system with wired backhaul. Roon core is is connected directly (wired) to a switch and then an Eero (and has been for years).

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

4 or 5 HomePods via AirPlay (wifi)
Devialet Phantoms via RAAT (ethernet)
Devialet Expert Pro via RAAT (ethernet)

Description Of Issue

Everything was working fine last night. This morning, however, Roon reports “No audio devices found.” The “Audio” tab in Roon settings is completely blank (tried on both an iPad and a MacBook). I tried restarting RoonServer and then rebooting the Mac Mini: neither made a difference. I also tried (based on a prior support thread for another user) stopping RoonServer and renaming the RAATServer folder to force Roon to create a new one. Again, didn’t make a difference; so I put the original RAATServer folder back.

So far as I’m aware, nothing changed between last night and this morning: no Roon update, no OS updates, nothing. Baffling.

The network is also working fine. I can play Apple Music via the HomePods with no issue and am, of course, using the network to send this report.

Hey @amg, I agree, that’s pretty baffling. Thanks for providing a detailed report, can you also try rebooting your Eero system?

1 Like

3 posts were split to a new topic: Audio devices disappearing – “error loading page”

I restarted the Eero network (the app has a feature to reboot every access point at once), and that didn’t fix things. I also tried rebooting the server again. No fix.

I really have no idea what it could be. Everything was working fine yesterday. And now there’s nothing at all in the “Audio” settings, not even the outputs on the server (e.g., the Mac’s built-in audio output):

Thanks for the extra info, it’s a bummer the good ol’ reboot the network didn’t do the trick. :confused:

Does your Mac Mini have a wireless connection configured in addition to wireless? If so, can you try disabling Wifi on the Mac Mini?

Failing that, we’ve seen using Google DNS help with similar reports. Can you try using Google DNS and let us know if you notice a change? Here’s Eero’s instructions for how to change your DNS settings:

Tap the Settings tab, then select Advanced. Select DNS, then tap the Custom DNS bubble to enter your desired DNS server.

The wireless connection is already disabled and my network (including the server here) is already configured to use Google DNS.

Anyway, the problem is not just reaching network endpoints: Roon’s not even picking up the server’s built-in audio output.

Hrm, in that case, let’s have you try generating a new RAATServer instance on the Mac Mini with the instructions below.

But please note that this will reset Roon Settings > Audio back to default, so I would advise making a backup of any custom DSP settings you have:

  1. Create a Backup of your current Roon database
  2. Close RoonServer
  3. Navigate to Roon’s Database Location
  4. Find the folder that says “RAATServer”
  5. Rename the “RAATServer” folder to “RAATServer_old”
  6. Reboot the Mac Mini and launch Roon
1 Like

I tried that already, as noted in my initial message.

Anyway, just tried it again. It does create a new RAATServer folder, but that’s about it. Still no audio devices.

Ah! Sorry I missed that. One last try before I escalate this to the technical team to take a deeper look – let’s have you try a full regeneration of the RoonServer folder, then restore from a backup. If you have any backups from before you ran into this issue, use that backup in step 5.

  1. Create a backup of your Roon database
  2. Close RoonServer
  3. Rename the RoonServer folder to “RoonServer_old”
  4. Launch Roon
  5. Restore Roon from your backup
1 Like

So that took a while, but it did work. Thanks!

1 Like

Great news! Thanks a bunch for your patience.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.