All audio devices no longer found AND no access to my Tidal library [Resolved]

Roon Core Machine

Windows10 PC Intel(R) Core™ i7-6700 CPU @ 3.40GHz 3.40 GHz RAM: 16.0 GB (15.7 GB usable)

Device name MRCStudy
Processor Intel(R) Core™ i7-6700 CPU @ 3.40GHz 3.40 GHz
Installed RAM 16.0 GB (15.7 GB usable)
Device ID 282C2033-A0A9-412F-9778-853E7C778855
Product ID 00330-80200-78481-AA425
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Networking Gear & Setup Details

Netgear 16 port switch. PC Core is ethernet cabled to my home theatre which is connected to my Trinnov Altitude16 … this is my main listening room for my Roon music.

Edition Windows 10 Pro
Version 20H2
Installed on ‎27/‎09/‎2020
OS build 19042.1110
Experience Windows Feature Experience Pack 120.2212.3530.0

Connected Audio Devices

My primary Roon endpoint is a Trinnov Altitude 16 processor that is ethernet cabled to my PC Core. I have Sonos speakers in my Study and Master Bedroom.

Library Size

Library approx 2000 tracks … not enormously large!!

Description of Issue

This morning when I launched Roon from my PC Core it took a long time to load and when it eventually did, I get the message that NO audio devices have been found. Also I get the message “Error loading page … Please check your network connection” when I attempt to examine my Tidal collection (I am a Tidal subscriber).

I have a Sonos system in my Study and Master Bedroom and this is all working (wirelessly of course).

Please help !!
I have NOT done any updates to either Roon OR Windows recently so this is rather baffling.


Ok … when I tired a second time launching …now the Audio devices are found, but still no go with connecting to Tidal. This is baffling …

Then when I try another time to launch Roon … the same condition presents: No audio devices found and NO Tidal access.


This may help too …

Had Roon hanging on launch, then no audio devices (or any way to add)…

Restored database then Roon wouldn’t launch at all, reinstalled Roon, then was able to login to tidal and everything is working.

I would try reinstalling Roon first as the database takes a while to restore… If that doesn’t work, restoring the database and then reinstalling roon (loging into tidal again) worked for me.

Ok …I have re-installed Roon but I found this did not make any difference … how do you restore the Roon database?

When I again launch Roon, intermittently it WILL find my Audio devices (just did then). But no joy with my Tidal library. Roon can only find some Apple music files on my PC. Currently it has found 176 tracks out of the 2000 that I had including my Tidal music in my library.

Some replies I’ve read state to remove the Tidal account and then re-add it.

To restore the database, go to the settings/backups then find backups which will give you the option to restore.

Ok … I have initiated the Restore backup option … in progress now!!!

After doing the Restore database … I was asked to login to Tidal to re-confirm my login credentials … after doing this it seems that Roon is now BACK to NORMAL.

Very weird behaviour indeed !!!

Ok … fired up my iPad which runs my Roon remote … and it cannot connect to the Roon core !!! It is asking for me to confirm my network settings and firewall … which I have NOT touched … Geez !!!

ok … I chose to select a different CORE and then I navigated to the CORE that has been previously used. Talk about a convoluted set of events. So all is good for now … I am now HOLDING MY BREATH that nothing else goes wrong !!!

Roon support … I did nothing to precipitate all of this … is there an explanation today ???

You positive Windows did not update itself since you last used it? It can cause all sorts of fun when it does.

Yep … I am sure since I decide when I get Windows to update.

Hi @Montgomery_Campbell

Have things continued to work okay for you now? It’s hard to say for sure what might have happened here, but if you see any issues return I’d be happy to take a look at logs from your install so we can get a better look.


Yep, today is bad Roon’s day. Same. Today Roon died, after restore no devices found. Solution? On Core logout from Roon Account and logon. Simple but sad is that something with communication RoonCore-RoonDataCenter is not good. Also Tidal not work for me, the same solution here - logout/logon.

Yes things are still working at present …