All DSD albums have disappeared

I’ve got RoonServer running on an Intel NUC, brand new Win 10 OS, set up less than 24 hours ago. All was fine, playing my NAS based MP3’s, FLAC’s, and DSF files. Everything flowing thru my Musical Fidelity MX-DAC.

I have not been testing for sonics (SQ), just function. Though I’ve never tested this on my old digital jukebox setup, I downloaded some 128fs DSF files to play as a test. To be fair, I’ve never tried more than 64fs DSF files before, though my DAC is supposed to support them.

When I tried to play the 128fs files, Roon locked up. I made some minor adjustments to settings, hoping to clear things up. But the result is that RoonServer now believes ALL my DSF albums are no longer there!

Happy to provide more details… But maybe I did some fundamental “no no” that will correct things.

If so, please advise. Otherwise… Not sure what to say other than say “Help!”


Apologies… Wrong forum.

Admins, can you please move this to “support”?


First - Admins, thanks for moving the tread!

Next - more information, that will hopefully not lead to wild goose chases…

I went into the RoonServer setup and changed Max Sample Rate from “disabled” to “up to 192 kHz”. That changed status immediately to the renewed recognition of DSF files. But unfortunately they were “there”, but would not play. This was - BTW - the original setting before the problem,

I also changed the “max DSD sample rate” to “up to DSD 128”. No change… DSD files recognized, but not playable.

Previously, in the functional state, I had an Audioquest Jitterbug in the PC to DAC path. Though it worked before, it has been removed no. No change.

Please repeat that last statement, but change “Audioquest Jitterbug” with “Schiit Wyrd”. Worked before, but not now.

As before, “Help!”


Sorry. Neglected to mention having executed every possible re-boot combinatation that my mind can comprehend. No change.

That plus the complete reinstall of the MX-DAC drivers, to no change.

After spending money on a cranking NUC to support this, I’m a hair away from declaring Roon “not ready for prime time”, thanking my lucky stars that I did not shell out for a lifetime license, and moving back to LMS (under Linux) that WORKS.

But would be DELIGHTED for this silly problem to go away, and keep using this beautiful interface. So still delighted to get help if it’s there. But if I can’t get good DSF support, this is a non-starter.

Thanks, in advance for the help.

I am sue the Roon guys will take a look. In the meantime, have you done a quick search on DSF in the rum to see if there is any useful info already posted?
E.g. DSD over PCM setting?
E.g. Checking that you DAC can handle the 128 native files ? (Just wonder as you mentioned you only just download them)

Btw…I run on a NUC too and it is rock solid on hires, DSD etc.

Thanks for the suggestion Nick. I’ve done a pretty solid search in the forum, and I’ve not found anything like this.

And yes, my DAC absolutely handles 128 native files. But that raises an interesting point worth noting…

My DAC has a Windows driver, and it’s only certified through Windows 8.1. My NUC (and RoonServer) is on Windows 10. So it’s conceivable that there’s a problem with the driver. But I would not think a driver problem would cause all DSF files to disappear from my library. Not play, sure. But disappear?

Which - BTW - they are gone again. They reappeared briefly last nite - though unplayable - and spontaneously disappeared again. I’d not made any changes.

Since that time I’ve tried every DSD setting imaginable, and those files remain missing from Roon. Though they do still exist on the NAS where they reside. I checked.

I realized last night that since I set this RoonServer up so recently, I’ve got a recent backup that I used to set it up. So I’m going to remove and reinstall RoonServer, and see what that does. Nothing to lose…

Just to test the DAC, I connected my DAC to my old media jukebox: Logitech Media Server and Squeezelite running under Archlinux on a Cubox-I. It found the new DSF128 file and played it beautifully. So it’s not the DAC. Though there could be a problem with the Windows driver.

I uninstalled my NUC’s RoonServer (software and data), copied my backup from a couple days ago back to the NUC, and reinstalled RoonServer. The good news - for me - is that my DSF files are no longer missing. And the DSF64 files play. The RoonServer tries to play the DSF128 files, but no sound. The lights on the DAC indicate that it does not even recognize the data coming to it.

This SHOULD be the same data that I just played with my Logitech Media Server (both LMS and Roon pulling from the same NAS), but whatever is being presented to the DAC by RoonServer unrecognisable. But I’m not going to bash Roon for that - until Musical Fidelity releases a Windows 10 version of my DAC’s driver, there’s no way to know where the problem is. Could be the driver. However…

My DSF files disappearing yesterday was both bizarre and unsettling. IMO this unfortunately is an indicator that frequent Roon database backups are called for until the software is a more stable. Going to have to set that up. Bummer.

Hi Steve,

Pleased to hear that some of the issues may have been resolved. There was a small number of users who had database problems in 1.0 and so the devs rewrote it in 1.1. That was a pretty big solution to resolve a problem that only a few had experienced, but stability issues are taken seriously. As you very rightly point out, backups are a great idea when such issues arise.

The only in app controls that I can think of that affect different res DSD are the Max DSD Sample rate in Output Settings. The behaviour you have reported there is quite odd. You’ve probably tried toggling Exclusive Mode and Event Driven Exclusive Mode, sometimes just turning those things on and off has flushed out gremlins.

Your DAC driver shouldn’t be affecting DSD tracks appearing in the library, but is a potential source of the playback issues. Are there other drivers you might try ? Sometimes ASIO, JPlay or other third party drivers can be separately configured as outputs. Is there a forum for your hardware ? It may be that others are finding a similar issue with Windows 10.

Sorry I can’t refer you to threads with similar issues; I haven’t seen any. @mike will pickup this thread on his rounds now that I’ve shifted it into Support and hopefully be able to help.


Andybob - thanks for the reply. Before I reply to you, I need to provide an update…


My last post was mistaken. After having reinstalled everything, and performing the tests I mentioned, apparently I neglected to ensure that my DSD Playback Strategy was set to DSD over PCM. In fact it was still in the default setting of Convert to PCM. So THAT’s what was not working with DSF128 files. Having seen that mistake, I’ve set it to DSD over PCM, and I’m listening to RoonServer play a DSF128 file as I type. Awesome! And sorry about the prior bad information.

Question is… why did this not work yesterday?

Andybob - in reply to your positing that I might have been toggling Exclusive Mode or Event Driven Mode, i really don’t think I did that until long after the problem started, when - in desperation - I began trying any/everything. Granted I’m operating on memory, but I REALLY don’t think I messed with that until later. As I recall, the events happened like this…

  1. I tried playing a newly added DSF128 track.
  2. The playback on my Roon remote froze. Not Roon, just the playback. It would not play.
  3. I went into Settings, and tried changing Max Sample rate. I THINK it was in it’s default state of Disabled, but am not certain.
  4. Then I changed the Max DSD Sample Rate. As before, I think - but don’t know - this was in the default Disabled state.
  5. I went to look for the DSF128 file, and it was gone.
  6. I went looking for my DSF64 files - also gone.
  7. Then I put the above settings changes back, but the files remained gone.
  8. Then I started tinkering with anything DSD related in the hopes of causing the magically disappearing files to reappear, including toggling Exclusive and Event Driven Modes.

As before, it was a pretty bizarre episode.

Musical Fidelity’s support is somewhat thin in the US. This I know from experience. But there is another “device” that I could try…

This whole episode has been on the “device” that in the Roon Settings Audio tab is listed as “Musical Fidelity MX DAC USB 2.0 Audio”. But there’s another device listed, called “Musical Fidelity MX DAC ASIO Driver”. Having read of the sonic benefits build into Windows 10 WSAPI, I’ve stayed away from that.

It is my hope that you guys will get this software rock solid stable. If there is more info I can provide - or anything I can test - to help you support your progress getting there, please let me know.

Thanks for the help. I’m working now. And backing up. :wink:

PS - Should you be wondering, I’m rock solid certain that the DSD Playback Strategy was set to Convert to PCM yesterday when this trouble started. I think. :smile:

That’s great news ! Hopefully the database issues can be fixed too.

When I spoke of toggling the Exclusive mode switches I meant it as a suggestion which has sometimes gotten things working. You weren’t doing anything incorrect by trying that.


Glad you figured it out. The first e.g. I noted above was the key.

Wonder how to make this a good search result ?

Well… actually not. I mean it was after I reinstalled. But initially - when the problem started - it was set to DSP over PCM before the problem started. I’ve been listening to a good bit of DSP music, so I was certain to make sure that was set properly. In fact I’ll go of topic a moment (it is my thread, after all :slight_smile: )…

My CD player is really just a transport. And my DAC can be switched from input from the CD transport (coax) to USB (RoonServer). So in those cases where I have DSF albums that are duplicates of CDs I own, it’s fascinating to do A-B listening of a CD, then the DSF. It’s great because the only difference between the system playing A and B is where the bits are coming from. Every other component is identical. And I can tell you that anyone that doubts the superiority of good DSF material over CDs needs to come to my house. :wink:

And THAT is why I know that I had DSD Playback Strategy set to DSP over PCM when the problem started. That’s how it ALWAYS is, except for this afternoon after the rush of reinstalling.

Thanks for all the help.

Thanks Andybob. The database issues ARE fixed. They were fixed when I reinstalled RoonServer with a backup. Nothing else would do it. Thanks. :slight_smile: