All embedded cover art are shown empty. Please help

Core Machine

QNAP TS-451+ 8GB ram

Network Details

QNAP Nas connected via LAN to the router.

Audio Devices

Auralic Streamer wired via ethernet

Library Size

7000 Albums with 75k Tracks

Description of Issue

After a backup restore (needed because of HD failure) i have an issue with all the embeeded cover albums in my tracks/album.
Every single file of my library has embeeded cover art in the flac file and i can see the pictures in Jriver or Mp3tag correctly.

Roon, after the restore, shows all the embeeded cover art empty (black/gray empty square). An example below:

I have tried to rescan the albums and to change the library folder…but the problem persist.

Below you can find the logs (zipped) i downloaded from the Roon Core.

Please let me know if this is fixable somehow…as it’s really annoying.

Thanks in advance


This text will be hidden

Did you clear the image cache under setup?

Hi James, yes i did it on all my clients (notebook and phones) but still all the pictures are showing black.

How long ago did you do the restore?
Any chance Roon is still busy analyzing the library?
I assume you have rebooted everything under the sun just in case…

I did the restore this morning. It shows that Roon has already finished the scan/import…in fact everything is fine except the covers.
And i’m talking about all of them, so 7k albums, showing empty image in the ‘‘file’’ option.
Unfortunately i don’t have another backup available…only this one.

The initial scan/ import is different from the analyzing that Roon then does on said files.
I find when I add new albums, if a lot, it will show me the albums but no cover art until it has finished analyzing them all.

See photo.
Do you see any action where it says analysis?And if so what do you have it set to? Fast or throttled?

Hello Kevin, there is no ongoing analysis. I know what you mean about the initializing time…but this is something different.
I’m pretty sure that the explanation is in the logs, but I don’t know how to read them properly.

Ah well, it was worth asking.
Hopefully someone will be along soon with some better ideas :slightly_smiling_face:
Hope you get it resolved fairly painlessly!

Anyone that could be able to help me?

Anyone that knows how to read the logs in order to understand what exactly happened?

I really don’t want to download manually 7500k albums cover…


Have you tried to uninstall and reinstall the control app on one of your phones?
I once had a similar problem and this helped for me.

Thanks for the suggestion Arlen…unfortunately it didn’t work. Still all the embedded pictures are shown black empty.
If you guys check the screenshot i posted…I’m able to see the correct resolution of the picture but they are all black/gray.

Apologies for the delay, @Miracle1980! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Are you still seeing this issue?

Hello Dylan, at the end i “solved” the issue restoring a very old backup.
I think the issue was related to the malware that crypted all the files on my NAS.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.