All music and audio devices disappeared from Roon

Core Machine (Operating system/System info/Roon build number)
MacOS 10.14.6
Roon 1.6, build 416

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

CenturyLink Gigabit, Actiontec C3000A
Core connected by Ethernet
Raspberry Pi endpoints wireless

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Raspberry Pi wireless to USB Meridian Explorer2
Raspberry Pi wireless to PS Audio USB 2
Raspberry Pi wireless to PS Audio USB 2
Apple TV 4 wireless
Apple TV 5 Wireless

Description Of Issue

All music and audio devices have disappeared following restart of Roon.

Library folder path is correct in settings and music still exists in library.

Both Tidal and Qobuz subscriptions have “Syncing Library Now” showing in edit tab.

Current network connection is active and strong. All Airplay devices, including Raspberry Pi Shairport devices appear in iTunes.

Repeated restarts of core do not resolve issue.

Hi @Bob_Worley,

Can you share a screenshot of Settings > Audio?

Can you see the server from another pc or device, sounds like it’s not seeing the network at all.

Should I delete my copy of Roon on the core machine and reinstall?

Would there be any other files I would need to delete?

The core is still showing both Tidal and Qobuz subscriptions syncing with no music added.

It also is not adding music from my local library although the path to the library appears to be correct and the library is visible in iTunes.

Still shows no audio devices found.

It appears that the core must be corrupted somehow and doesn’t see the network at all.


Yep. Core device is headless and I connect to it remotely and have no difficulty connecting to that machine.

1 Like

I’ll let proper support answer in that case.

Here is a screenshot of the main screen

My original post was slightly incorrect, the core machine is running Roon Server. It also has a copy of Roon installed as a control device. The regular copy of Roon is not currently open on the core machine.

One thing you could try before @support chip in again is to close everything including the network devices. Then restart network first then core etc.

Thanks. I’ll give that a shot. Pretty frustrating, have a day to listen to music and have resorted to streaming via airplay through iTunes.

They know. That’s why your printer runs out of toner just when you need that critical document…
Be afraid…

Hi @Bob_Worley,

Can you please confirm if you have any backups of your current Roon database? I have activated diagnostics mode and what this action does is automatically upload a log set from your Core to our servers for analysis. I can confirm that logs have been received, and I have asked QA to review them, but this process may take a while until it reaches their queue. If you have a backup, I would suggest performing the following steps:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Restore Roon from a backup

Can you give those steps a try and let me know if it helps with the issues?

Currently restoring from the most recent backup. From first appearances, it looks like letting Roon Server build the new file on reboot is working. Opening a remote, I was able to see audio zones and upon logging into services, albums began to add, same with signal path.

I disabled both Tidal and Qobuz, and cleared library folder path information, and made sure all audio zones were not enabled to reset Roon to clean settings before beginning to restore from the most recent backup.

Fingers crossed!


1 Like

Hey @noris your suggestion worked! I’m back in business. Always scary to have to restore anything from a backup, but happy I run the Roon backup function nightly and that the restore function works.

Thank for your help, and thank you @ged_hickman1 for your suggestions, too. Hadn’t rebooted my router in a while so I’m sure it didn’t hurt anything. :grinning:

You can mark this done and close the thread.

1 Like

Ha! They can get complacent if you don’t…

Hi @Bob_Worley,

Glad to hear that restoring from the backup worked as expected, thanks again for reaching out to us!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.