All of a sudden cant play DSD through HQPlayer and Roon

Hello,

So this morning I opened up HQPlayer and noticed that whenever I have my Default Output Mode to SDM(DSD), the files still oversample and output in PCM.

Im not sure what to do about it. Ive tried HQPlayer standalone and through Roon, but both offer the same problem. I havent changed any settings recently. Is reinstalling the best move here?

Cheers,

Jonathan

It may not be the case here, but what you are describing , is that your DAC is supporting DSD using DOP, and DoP is not activated.
You should verify if your Dac requires DoP for DSD supportthis, and also check in HQplayer config screen if DoP is enabled when applicable.
Dirk
Do n9t start reinstalling, is of no use.

If you are outputting to a Holo Audio Spring then it doesn’t require DoP.

I presume it is a Spring 2 since you have 48k DSD enabled.

It may be that you are using a 44.1k family source file. If so then by ticking Adaptive Output Rate you are telling HQP to always convert the source to the max sampling rate of 48k x 1024 DSD.

But you are using a closed form filter, which can only output integer multiples of the original source fs. So try greying out Adaptive Output Rate instead of ticking it, which will let it fall back to 44.1k x 1024 DSD as needed.

This would explain why you may have seen DSD output in the past when using 48k source files.

I would, however, have expected no output rather than PCM when forcing HQP to upsample 44.1k source file to 48k x 1024 DSD with closed form. So I might be completely wrong !

What sort of computer are you using to upsample to 1024 DSD ?

I presume it is a Spring 2 since you have 48k DSD enabled.

Yes, it is a Spring 2 running on NOS mode, USB input.

As of right now, the only way I can get hqplayer to oversample to DSD is the following way, and no diverting from these exact steps.

  1. Start HQPlayer.
  2. Set it up to output to SDM(DSD)
  3. Save Settings
  4. Open Roon
  5. Click song to play
  6. Song plays in oversampled DSD at whatever rate i want.

As soon as I click file/settings in HQPlayer with roon open, the music will pause and then switch to PCM rates. To make it play DSD again, i got to close hqplayer and roon and do the steps 1-6 again.

I attached screenshots of what hqplayer settings im using, along with the error I get where hqplayer switches to PCM from DSD whenever i click on settings and try to save while Roon is open.

Also, in regard to the Multicore DSP , CUDA Offload , Adaptive output rate settings at the bottom of hqplayer settings. If I have the boxes grayed out or unchecked I get stuttering in hqplayer. I HAVE to have them checked marked for hqplayer to play DSD 1024 without stuttering for whatever reason.

What sort of computer are you using to upsample to 1024 DSD ?

i9 9900k 4.8 ghz, 2070 super , 32gb ram, 2tb SSds.

Moving from closed form to ext2 filter has “solved” the issue in my previous post. But I would have expected your computer to be able to handle greyed adaptive rate (only, don’t grey Multicore or Cuda) without stuttering on closed form. It’s not an increased load for one thing.

Opening file/settings in HQPlayer always stops playback but it doesn’t result in reversion to PCM settings for me. Let’s flag @jussi_laako and see if it is something he can help with. .

Sounds like you may have the DAC enabled at Roon side as well. This would create conflict and cause various kind of problems. What ever audio device you use for HQPlayer, please make sure that it is disabled at Roon side.

1 Like

Cased closed. This fixed it! Thank you both for the help

1 Like