All of a sudden I’m missing thousands of artists and albums

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Well filling in the missing information requested might give us all some clues…

1 Like

What other information do you need?

Almost all of my artists and albums are gone from my homepage.

Thank you

These details would help. Also, tell Support whether you have local files, and where they are held.

This is my signal path.

Roon nucleus to stream Tidal through LUMIN D2 out Macintosh integrated to B&W.

All of my library was housed on my nucleus. Now it’s almost all gone

Thank you

You’re still not providing the details asked for - I’m having to make guesses and assumptions about what your situation is, so I would expect anyone in the Support team would have to do the same. This makes it difficult for them to achieve a rapid diagnosis of what is going on.

What is your network setup and hardware?
How many tracks are in your library?
Are these all Tidal tracks, or do you have local albums and tracks?
Give examples of missing artists and albums - are the missing albums sourced from Tidal or stored locally on the Nucleus?

in this case a picture is not painting many words at all.

Thousands of tracks, albums and artists all sourced from Tidal stored on the Roon Nucleus I presume.

Simple system - just a Roon nucleus as my core. Tidal as my source streamed through LUMIN.

I’m sorry I’m not sure what else to say. I can try signing out if Tidal and signing back in?

I rebooted the Roon nucleus.

It’s like everything disappeared on the Roon Nucleus.

Thank you for your help.


The exact same thing used to happen with me and Qobuz - infuriatingly, from one month to the next I was never sure if the dreaded ‘culling’ of tracks would happen. I have about 700 of my own albums and about 7000 Qobuz favourites (dumb, for certain, but it is what it is!). When the culling happened I would collapse down to my local albums.
Ended up being accepted as an issue concerning the way Roon and Qobuz talk to each other. I mean, it is complicated and disasters happen.
For several months now, the culling has stayed away. Seems like R and Q talk nicely to each other now.
Maybe your issue is just the same sort of problem but Tidal based?
Anyway, whatever I did at my end NEVER solved things. It’s not an individual user issue as such, more a network communications snafu.

Right - so what you are saying is that you have no local albums - your library is entirely sourced from Tidal?

So then the next step is to try signing out of Tidal (in your Roon settings), restart your Nucleus and then signing back in to Tidal again to see what happens.

Thanks Fellas,

I’ll try signing out of Tidal in Roon, restarting the Nucleus, and prayer :joy:

Thank you,


Are you keeping regular backups ?

If all else fails you could restore an old backup from when you were happy with what you had

Takes a little while but should reset everything

Mike, I don’t think this should be necessary. Assuming that Mark has “favorited” all his artists and albums in Tidal, then these should automatically be synced into Roon.

The issue is, what has caused these items to be lost from the Roon library in the first place?

I have “favorited” all of my artists and albums in Tidal.

I’m going to try signing out of Tidal when I get home from work, rebooting the Roon Nucleus and then signing back into Tidal on Roon.

I am perplexed by what has caused these items to be lost from the Roon Library in the first place as Geoff has stated.

Many Thanks.




I logged out of Tidal, shut down my Nucleus, then restarted Nucleus and then I logged back into Tidal all through Roon and voilà, my albums, artists and tracks are back.

Many thanks for your suggestions!

I still don’t understand why this happened but I’m grateful to have my music back.

Two+ years of Roon, lifetime subscriber and I still like Roon. Hopefully this is a rare occurrence.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.