Allo Sparky and DietPi...unstable

(KMP14) #1

Anyone else having problems with the Allo Sparky and Roon running DietPi?

I have an Allo Sparky, the latest DietPi, and a Piano DAC, wired Ethernet (4 zones). Whenever I add this combo to my usual grouped combination of Zones, mostly Raspbery PIs with various DACS (Served by an I7 ROCK), things get unreliable and I get frequent skips to the next track. Remove the Allo Sparky and my system runs along smoothly with no skips. Add it back and things go bad again. I dont have any DSP happening in any of the zones.

I have tried different Ethernet cables to the Sparky, different Eth ports. I have tried the Sparky alone, and still have the same skip problem.

It is a clean install of DietPi with only Roon running on it. It is a bugger…

(Mr Fix It ) #2

If you remove one of the RPi’s and leave the Sparky connected is it ok? Maybe you are reaching the limit of your core? And dsp or other such processing going on?

Oops missed the Sparky alone bit…maybe a tag for @allo.com and @Dan_Knight

(KMP14) #3

I also mentioned that in my post, No DSP going on.

(KMP14) #4

Thanks for tagging them!

(KMP14) #5

I was having the same problem with the Sparky a few months ago, and just unplugged it. Fast forward to yesterday, and I decided to rebuild it, fresh DietPi image, and the same results as a few months ago.

(Mark) #6

Perhaps you have two sparky’s with the same name? In older versions of dietpi when two devices had the same name this caused the type of issue that you are relating. If you do have such other device, remove it from the network before adding the offending sparky. If the unit now works, add back the pervious unit…if systems run amok…

(KMP14) #7

Sorry for the delay in responding, I have not had a chance to look into this. I only have one sparky, but I may have a Rpi with the same name. I will follow up here if I find that this is the issue. Thanks!

(KMP14) #8

So I confirmed, I only have 1 sparky, and that 1 sparky is the only gadget on the network with the name I gave it.

(Mr Fix It ) #9

@Kenneth_Price Its a long shot but there was a post recently that the USB 2 ports seem to not work with USB powered DAC’s on Sparky…could that be the issue…maybe this is a power supply related issue even?

(Mark) #10

Ken, not so much a case of the name “you gave it” but the name that dietpi gives it with the Allo cards…If you are using the allo gui, you can find this in the system settings screen I believe. Also my recollection is that this happend with an older dietpi version, with 159 this should not happen, so an update to dietpi could cure.

(KMP14) #11

I am on the latest DietPi. It is headless, although I am not sure what you mean by “allo gui”, I assume that is something you would find if connected to a monitor via HDMI? Since it is the only Sparky in the house, I would also assume that naming is not the issue?

(Mark) #12

ok, I’ll try to answer. Your Sparky has a Piano Dac? If yes and if you also have an RPi with a piano Dac on your network its possible that the system names of the two units are the same. I had an experience where this caused the symptoms which you are describing. I would take this up with Dan Knight, seems like a DietPi issue to me.
The allo GUI (if installed) is accesable from any browser by inputting the IP adress, there, after logging in, you could see the system name.
BTW are all your other Dietpi devices also upgraded, or could the other unit with the Piano (if there is one) be on an older offending version?

(KMP14) #13

Interesting…there is another Piano DAC in a DietPi/Raspberry Pi on my network. Thanks for sticking with me on this. I will look into getting the allo GUI installed on the Sparky, but I am now wondering if there is another way to view what name dietpi gave it, epsecially on the Raspberry PI unit.

(Mark) #14

As I said earlier. Disconnect the other unit and see if the Sparky works. If so. I’m on to something. Dan Knight is the developer of DietPi, get in touch with him.