Allo USBridge board


(Paul Hermans) #1272

I was surprised that the USBridge came with the old v6.9 dietpi.

But at the end very pleased with what I have.


#1273

Rahul (Allo) replied above? rahulkc_s


(Richard Robbins) #1274

@Barrowboy – You are correct. My oversight. Apologies to @rahulkc_s.

More importantly, I am pleased that my USBridge is now up to date and functioning properly.


#1275

Have good Xmas.


(Trebz) #1276

@bevan_court Thanks for this post. I have been struggling to get a USBridge working, when my Allo Boss player just worked with the Sprout 100. I was hoping to give the Allo Boss to my son.

I am doing an update now, and if it doesn’t work, I think I will order another Allo Boss running DietPi.


(bevan court) #1277

Maybe give the Allo Usbridge to your son if he has a different dac? I’m fairly sure it is an issue with USB drivers of the Sparky, which is on an old Linux kernel, and the Sprout, some sort of incompatibility.

As a suggestion, if you are only running Roon, Ropieee is definitely the easiest end point to set up and much more robust than either Volumio or Dietpi.


(Trebz) #1278

I did get everything working using the latest firmware last night. Turned out the updates were failing because the time/datewas set to May 2018 and the checksum wasn’t validating the download.

Once I did that it went through a lengthy update process, and then started working once I selected the proper soundcard. After several hours, I was ready to give up but all seems to be well.

Still not sure which I am going to keep for myself. The Allo Boss plugged in via analog, or the USBridge via USB.

I won’t have much time to test it out to see which sounds better on the Sprout 100. The Allo Boss looks much better, that is for sure:)


(bevan court) #1279

I found that the Allo Usbridge just didn’t play nice with Sprout 100, maybe my network, it was a shame because when it worked it sounded nice. Now using a Pi with WiFi and Ropieee and it just works. The addition of a ifi USB iSilencer has left me satisfied.


#1280

Not to beat a dead horse here, but it’s been a year. Hasn’t the time come to accept that Actions Semi simply isn’t going to do it ?

If the USBridge magic comes from the board rather than the Sparky, is there anything that prevents switching to a SoC with manufacturer support ?


#1281

I am having a problem with my USBridge similar (the same??) to an issue I had in the summer of last year and I need some help. With my previous issue Allo sent me a reconditioned USBridge board which I installed and it has been working fine until now, the original problem was the USBridge was faulty and I could not select or use it as an endpoint in Roon.

With the reconditioned board installed I have been using the USbridge in my desk set-up feeding my Arcam irDACII via usb. I have the j28 jumper removed and I have an IFI wallwart feeding USBridge and the standard supply feeding the sparky. I am connected to the clean USB output. The USBridge is on 24/7 and does not get turned off at night. I have version 6.19.7 Diet-pi installed.

The problem is basically that Roon is not recognising the USBridge properly, see image.

When I go into the Allo web interface to try and save a soundcard in the system settings if refuses to save, each time I try it comes up blank again. All of this means I cannot select the USbridge as an endpoint. When I look at the USBridge I have a solid red led which means it is powered I think and a solid blue on the sparky which means the same thing. I have a slowly flashing red led which means the OS has booted and is working properly I think.

I have tried fresh installs of dietpi on a MicroSD card and the EMMC with the same result.

Can anyone from @allo.com or @rahulkc_s or anyone else offer assistance? I hope I have missed something obvious (quite likely) and its a quick fix.

Thanks


(Mike Ormerod) #1282

Have you tried to SSH in and set up the Soundcard that way rather than using the GUI? I find the GUI unreliable at best.


#1283

Hi @Mike_Ormerod,

I haven’t no, but I will have a go now, although I need to figure out how to first!

Update - I just turned it on this morning to have a go and it worked! I could select the usb-dac in the GUI (I thought I would try one last time), rebooted and then I could select it in Roon. Weird. However, I do need to power down to reassemble the case, I hope this is not short lived! I will report back.

Update 2 - Still working!! Not sure what went on yesterday, I didn’t do anything except try again today.


(Geoff Coupe) #1284

I was in a similar situation as you - the endpoint disappeared from Roon (permanently). At first it was thought that the USB bridge HAT was at fault, but it turned out to be the Sparky board itself. That got replaced eight months ago, and since then I have had just two occasions when the endpoint has disappeared from Roon. A power reboot has fixed it both times (I have the USB bridge on 24/7 like you).


#1285

Hi @Geoff_Coupe,

Thanks for letting me know I am not the only one who gets this from time to time. I did try a power reboot a few times yesterday but its good to know this is the likely fix if/when this happens again.

Thanks
Ross


(Phil Knowles) #1286

Hi @Ross - from my experience, don’t bother with the GUI at all and SSH in to the unit. I use an app on my Windows machine called Putty to help with that. No issues with that approach and that’s also the best way to update the software too.


#1287

Hi @Phil_Knowles - I use putty also to update the USBridge but have not gone much further into the various options, I must have a good look through when I get some time.


#1288

Noticed USBridge out of stock. Refresh perhaps?


(Sean) #1289

Good question. @allo.com @ALLO_audio_boards?


(Jon Mansey) #1290

There one for sale here https://community.roonlabs.com/t/fs-nice-allo-usbridge-black-case-with-ipower-5v-psu


(johan ) #1291

Hi , we are currently out of stock and we should be having them in 10 days