Allo USBridge board


#1292

I just connected my Allo Bridge which I have not used in 8 months or so, upgraded to 6.19 and replaced the NAA I was using and I’m getting when I try to change the song / track a “ROON LOST CONTROL OF THE AUDIO DEVICE”, after I try 3 - 5 times the track changes and plays normally. If I try to move the slider to another segment on the same song there is a pause and same error, after 3 - 4 tries then it plays.

I don’t know if it is related to the new release or if this is something that’s been going on for a while

On my Allo Bridge all services are disabled except the HQP NAA and the network stats.

My chain Roon + HQPE running on NUC — NETWORK —> ALLO BRIDGE — USB --> DENAFRIPS DAC

UPconverting DSD 256
Any ideas what could be happening?


(Sean) #1293

I’m having this issue too since yesterday - also with an Allo DigiOne as NAA.

Both running DietPi. So maybe a DietPi thing? @Dan_Knight

I did a clean install on both and still have the same problem.


#1294

so it started with the new Roon’s release for you ?


(Sean) #1295

Yes but RoonBridge works fine for me.

It’s only NAA on USBridge and DietPi that have failed since the Roon update, so it’s strange.

Same Roon Core can play to a microRendu NAA fine - so it’s specifically DietPi and specifically NAA related for me.


#1296

My NAA on Intel is fine too, just the Allo hardware so it seems

Let me try using PCM instead of DSD and DSD128


(Sean) #1297

Running DietPi on the Intel?

If not, I wonder if it’s actually DietPi, not the Allo hardware.


#1298

No, running Ubuntu minimal install with networkaudiod


(Sean) #1299

Right so your non-DietPi is working fine. Makes me think it’s Dietpi.

But we’re only two data points.


#1300

it could be, if you just use the Roon Bridge as NAA (not HQP) does it works fine?


(Sean) #1301

Yes I mentioned that above already, which is why I guessed it’s specifically a DietPi + NAA issue, not DietPi alone.


(Angel Catala) #1302

Great! I just ordered an USBridge a couple of days ago in order to run NAA on DietPi :roll_eyes:

I wish it will be fixed soon.


(Sean) #1303

At the moment we have only two datapoints.

Hopefully other DietPi + USBridge/DigiOne + HQP NAA owners can share if they are having issues (or not).


#1304

I just tried to test PCM and it failed, the Allo Bridge is not seen anymore from the Roon Linux server, I am using the USB to Ethernet adapter connected on the USB2 (not 3) since in the past we had problems with the included adapter and USB3, that adapter is connected Back to BAck to the Roon Server, I have to see what’s going on. Since I haven’t used my DietPi bridge in a while don’t know if the USB3 can be used now


(Sean) #1305

Yes I know it well :frowning:

But can you access USBridge via ssh? So it’s on the network but it’s just a problem of Roon not seeing it?

Or you can’t see it on the network at all, even via your router’s config page?


#1306

Never mind is not disconnected just giving me the Roon Control error
Just tested again, switched from DSD256 to DSD128 and DSD64 and same issue
Switched over to PCM384 and PCM128 same issue

Just with the NAA on DietPi not with the Inetl one


(Sean) #1307

Cool, so RoonBridge is working ok for you on DietPi USBridge also?

Just NAA is the problem?

If so, then we both have the same identical issue, since yesterday it seems.


#1308

Trying to do some debugging, for getting the NAA logs (networkaudiod) you need to run dietpi-software and enable the logs correct?


(Sean) #1309

I have no idea about logs from NAA side unfortunately. Maybe @rahulkc_s can help?


#1310

no worries I think it has to be enabled, I’m in the process now


#1311

@Sean2016 Allo Support provided this. mine is at 0 I’m waiting for them to confirm indeed has to be set to 1

check cat /DietPi/uEnv.txt value aotg.urb_fix=1

this parameter set for HQplayer