Allo USBridge board


(Mike Ormerod) #1352

A further update. I couldn’t access using the local name, in my case musicroom.local. I tried the IP instead and could log in to the device. As soon as I logged in a whole bunch of processes kicked off which look like they continued an update process, including what appeared to be some new password related updated at the start of the process. I’m not 100% sure what just happened but it appears to now be working.


#1353

That is exactly what happened to me.


#1354

On a separate note, as I was fiddling around trying to get the USBridge to install the latest version I did come across the power settings when ssh’d in. I usually set this to ‘performance’ via the allo web interface. There are other options, ‘ondemand’, ‘conservative’, ‘performance’ in addition to ‘powersave’. In the text when ssh’d in it seem to suggest you might get less PSU noise and therefore better sound quality by setting the USBridge to ‘powersave’, is this true? I mean I can play around and try and hear a difference, but i wanted to get an idea of what others do and also what @Dan_Knight opinion might be. Thanks.


#1355

I have a issue with my brand new USBridge. If I turn off my M2TECH Young MKIII DAC the USBridge looses the connection to the DAC after a while. I have to restart the unit by powering it off. A simple reboot does not help. Interestingly the last used sample rate is displayed in the DAC (usually it shows UNLOCK without the sample rate).

I changed the line from 1 to 0: nano /DietPi/uEnv.txt aotg.urb_fix=0, but this does not resolve the problem.

Is there a solution or it is normal behaviour? @allo.com


(Dan Knight) #1356

Hi Ross,

I believe powersave on the Sparky will reduce CPU clocks well below what the system will need to run Roon.

However, in theory, reducing the power draw on any electrical device can reduce the chance of PSU noise and reduce EM/noise generated by the SBC.

Performance is recommended for the Sparky by Allo to improve device stability.

You could try limiting the CPU clocks in dietpi-config, will reduce power and performance usage.


#1357

Thanks @Dan_Knight. I have put both my devices back to performance for now. Although I didnt notice much difference when running on powersave.


(bevan court) #1358

I did the same thing. Ropieee just works and the Pi sounds pretty good. Enjoy listening more when I’m not getting cross because of software/hardware not working.


(Brent Burge) #1359

Hi Micheal - I just purchased an Allo USBridge and coming from a Mac background I’ve been soaking up all the info I can find on this thread - some of it is sticking :slight_smile:
I bought the unit to pare down my system to an endpoint for Roon instead of my macmini - running it as a Roon Bridge.

Mine is running dietpi at version 157 so intend to get it up to date, but I keep coming back to your post about setting the unit up as a “better” endpoint for Roon running Volumio, an creating a “high-speed true HD audio” device.
You mentioned you prefer dietpi - Does the process of installing dietpi create an endpoint for Roon that has this “HD audio” option? Or do I need to run an install similar to the one you describe for Volumio.

Sorry if I’m missing the obvious - it’s a journey of discovery where secrets keep appearing!

Many thanks - Brent


(Mikael Ollars) #1360

The DietPi route does the same thing but in a more efficient manner. Volumio is an embedded core and player within the same computing space, not a benefit at all for running a Roon Bridge on the side.

I also run a USBridge on top of a Sparky, with a slim DietPi+Roon Bridge install. Simple, stable, good sounding!
Any sample rate my DACs can take is supported (up to DSD256 and PCM768) which is more than necessary to me.
The Volumio comment previously might be related to the fact that Volumio is one of quite few that allows a HAT DAC to convert DSD and higher than 24/192 natively. This is due to a newer kernel component I think…


#1361

I just updated my digione and then my usbridge. The digione update completed successfully and I can boot back in via the allo web page and I can see it in Roon. The USBridge, I can’t log back in via the allo web page and I can’t see it in Roon, although I can SSH in. Any thoughts?

Edit - it was as simple as rebooting for a second time via SSH. All ok now.


(Matt M) #1362

I’m a happy USBridge user, feeding a Meridien Explorer2 that has been seamless for almost a year straight. I’ve finally scratched an old itch and picked up a Schiit Modi Multibit DAC, but have had no luck getting any audio out of it when connected to the USBridge streamer.

In Roon audio settings, the USBridge shows up as “DietPi” and shows four potential outputs available to be enabled. To date, I had enabled the one that shows as the Meridien Explorer2. Plugging the Modi into any of the other unused USB ports has yielded no audio output.

A few questions come to mind:

  1. Can I have two DACs connected to the Allo streamer at once? I assume this is possible, as my MacBook (Roon core) almost always has two DACs flawlessly connected (an Apogee Duet 2 and an iFi mico black label DSD).

  2. I realize the Schiit Modi Multibit is not Roon Ready (or even Roon tested, as far as I can see). Any users have recommended settings to account for the DAC’s limitations (i.e., no DSD, max 24/192 ?).

  3. Any way other than trial and error to determine which outputs on the streamer are which when all of them say “atm7059_link” ALSA in Roon settings? I’ve enabled them all for the time being.

Thanks.


(Mr Fix It ) #1363

@Gabbleratchet73 have you tried with just the Schiit as the old DAC on the USBridge?

does the Schiit show up on the MAC?
Maybe the USBridge can’t supply enough power to the Schiit


(Chris) #1364

The Usbridge only has 1 USB port that is intended for audio output, the other 3 are the ports directly on the Sparky SBC board and if you use them for audio output then there would be no point in purchasing the Usbridge as you can buy the Sparky on its own for under $30.


(Mr Fix It ) #1365

I was about to edit my post to say this too…but I think they should still support a 2nd DAC but power usage as I noted could be the issue.

I might go and try mine later…need to go see a client now tho.


(Albert Jochems) #1366

I successfully updated to 6.21 today via SSH. No issues at all: “Dietpi-update” - wait - reboot - play music :sunglasses:

Just thought it would be nice to share some good news as well.


(Vincent Kennedy) #1367

Complete newbie question:

I am looking for complete directions on how to flash the latest Dietpi to the emmc in one of my USBridges but haven’t been able to find a comptete set of directions from beginning to end. Does something like this exist?

Thanks in advance,
Vince


#1368

I’ve used this method several times successfully…

How to Flash Sparky eMMC With the Help of Linux Loaded SD Card


(Vincent Kennedy) #1369

@Wakajazz - Thanks!


(Matt M) #1370

Thanks. Good point.


(Derek Morais) #1371

My USBridge continually disappears from my device list. I have to reboot for it to appear then it works until the next time I want to play music. At first it was just a nuisance now it’s becoming annoying to the point that I want to get a new device. This has been happening since I’ve received it from Allo and through all updates. Using an Asus AC56 a 2.5a LPS and Allo PSU connected to Topping d50 via usb. It appears on my devices on my router so it is obviously something on the other end.