Allo USBridge Signature with Topping D90SE DAC - Compatibility Issue

I have an Allo USBridge Signature running Ropieee, I never had significant issues with it until I connected a new Topping D90SE dac to it last fall. The bridge crashes about every 4 - 5 days, to restore operation I disconnect and reconnect the power. Prior to installing this DAC this endpoint hardly ever crashed. I also have two RPI4 endpoints running Ropieee which never ever crash, they are also connected to Topping DACs, but earlier models. The previous DAC on this endpoint was a Topping DX-7s and it never crashed.

I am pretty sure the culprit is the DAC, but Topping’s support is worse than useless. I raised this issue with them back in January and they never responded. There were no FW updates for this DAC last time I checked. Topping after sales support it seems leaves something to be desired.

Is anyone having a similar problem with this DAC and bridge or any RPI based bridge?

I regard this as a nuisance, not a show stopper, but it would be nice if I could fix it.

I’d look at the log of the USBridge, find out why it’s crashing. Talk to Allo support, maybe they’ll be more receptive. Could just be that plugging in new hardware killed the bridge. Try connecting up the DX-7s again and see if that still works, just to verify it’s not the bridge.

I will try to extract the log. The bridge isn’t damaged, if I reboot it functions fine. It crashes typically every 5 days or so. I can swap the bridge into another system which now has the original DAC I used with it, and swap that endpoint to this DAC and see if the behavior is consistent.

I am hoping I am not the only one experiencing this strange behavior.

1 Like

Let me know if it works OK with the DX-7s.

If you’ve got a spare SD-card you could also try DietPi with AlloGUI and Roon Bridge to see if that fixes your issue.

I have a D90SE fed by a USBridge Signature over (of course) USB. The same device also contains the DigiOne Signature HAT feeding a Denafrips Ares 2 over coax. Everything works perfectly and I’ve never seen a crash. I’m running Ropieee 4.017 Stable and have not yet bothered to do the required manual upgrade to the Latest and Greatest.

For sure should have a look at logs and try all the other suggested ideas.

If it’s crashing every ~5 days, you could also configure Ropieee to automatically reboot every day at 4am and observe whether or not it still crashes and with what frequency.

So this sort of confirms that something is broken. How do you have your D90SE configured?

I shut off blue tooth tonight, apparently I did not do it before, auto power down is disabled.

Earlier on I did try having the bridge reboot, but not on a daily basis. I’ll try your suggestion, and I will trying swapping the bridges between systems and see what happens.

The USBridge just stops, no flashing LED and completely offline. Removing power restores it.

Some details

I’ve reconfigured to reboot every day, and will report back what happens. I can try swapping an RPI4 endpoint for the USBridge next, and swap the USBridge into the system with the DX-7S.

So you’re running the latest version of Ropieee and mine is the last of the pre-rewrite versions. Did you have the same issue with previous versions of Ropieee going back into (say) late 2021?

I’ve got my D90SE configured in pure DAC mode. Pre-amp, Auto-off, Bluetooth all disabled. FWIW it’s also in display saver mode, but I only recently switched to using this option.

One more thing: that stack sits by my sofa and isn’t in constant use. So it spends a good deal of time powered down. I guess it gets about 4 or 5 hours use per week. Sometimes less, sometimes more. I normally leave the USBridge powered up though, even if the D90SE / Denafrips Ares 2 / A90 are all powered down.

For the hell of it, I’ve just turned on the D90SE and will leave it on for a week to see what happens. But see next para.

Does sound suspiciously like it’s a problem with your USBridge. Definitely worth giving it a try with another DAC to see if the problem replicates before digging more into other possibilities.

Yeah it was a problem with the previous version of Ropieee, and started only with the installation of this new DAC. My belief is that the DAC may be doing something that crashes the bridge, but am not sure.

Your D90SE FW is different than mine apparently, there is no option on mine to select DAC or PRE-AMP mode in the factory settings accessed at power on by holding down the SEL button on the front panel. It’s not mentioned in my owners instructions either.

I have disabled BT and auto-off and enabled auto display blanking. I have reconfigured the bridge to reboot every night.

Worst case I will live with the inconvenience, the DAC otherwise works flawlessly and is by far the best sounding DAC I have owned to date.

I will follow the great advice provided so far to try and get a better understanding of where the problem lies in the event that it’s not actually specifically DAC related.

Wow… that’s interesting. Did you buy yours very early on? I bought mine last December when it had already been out for a while. If there’s any difference it’s almost certainly just in firmware and presumably it’s possible to update firmware on the device. Finding out where to check and how to do is best left as an exercise for the reader hehe.

Purchased in November last year, but was drop shipped from Shenzhen directly to me. Perhaps I missed something in the settings and I will have another look tomorrow, but it didn’t seem to have that option.

There are no FW updates available at this time. Interestingly Roon recommends using the DAC’s internal volume control option for level control. (I have some line transformers that don’t like 4Vrms at very low frequencies.)

What’s that burning smell?

You probably want to avoid 5V mode in that case, too. That’s Option 12 in my manual which I’ve just fished out. My manual has Simplified Chinese, English, and Japanese. In this version (and I don’t know if there are other versions for other markets) Line Out mode setting is the Option 3 described at top of the 7th fold from the left.

Yeah, I did avoid selecting that mode.

Well here is an update. I have the bridge set to reboot every day at 3AM and tonight, only two days since I made the change I found the bridge had crashed. (Normally it is about every 4 - 5 days.) This week-end I will swap the bridge for an RPI4 and move hopefully move the bridge upstairs to the system with the DX-7S and see what happens.

I created a new topic in the Ropieee forum after sending feedback, and posted the feedback identifier there as well as here.


I suspect it will turn out that this DAC has a problem. (Or maybe the compute module)

@Zaphod - could you try leaving your unit on for a week with auto off disabled and see if it does the same thing?

Edit: Well a little egg on my face, menu 3 has setting as you described and i have set it to dac and will need to reduce the input level to keep from saturating the input transformers in the line stage below 30Hz or so.

Also when I repower the DAC it makes a weird whiny hiss for about 3 - 4 seconds after I hit play in Roon after a reboot of the bridge or power cycling the DAC. I think this is looking like a DAC problem.

Sure. I set this up yesterday and it’s on.

Hi Zaphod,
Many thanks. So on the whining noise I commented on went away after I turned off the resampling option in Roon - I was resampling PCM 44k files to DSD256 moatly because I thought it sounded better on the previous DAC, on the D90SE it doesn’t seem to make a difference.

I will play a native DSD file after I reboot the DAC and see if this behavior is elicited.

Next time you are listening can you try resampling PCM to DSD256 and cycle the power to the dac and then play a resampled file? I am curious if you hear the same thing.

It looks like I found the cause of the problem. Harry asked whether I had other nodes running Ropiee, and apparently in the shuffle when I added the new DAC and moved the other two around two of them somehow ended up with the same name.(One of them was this one) I changed the name and I have not had a crash in over a week now. Hopefully this is the end of the story.

In short operator error. Zaphod, thank you for your assistance.

1 Like

No such luck it crashed tonight. I realized it might have been power interruption related or a repeat of the same old problem. Oddly disconnecting and reconnecting USB resulted in the endpoint resuming operation, but playback stuttered continuously until I rebooted the end point. I was also not able to access the end point by IP address although Roon could see it.

@Zaphod Can you confirm that you do not have this problem?