Allo USBridge Signature

I swapped back to the original USBridge on my Explorer² last night when I moved the Sig upstairs to my Prime Headphone amp. I am going to have to purchase another Sig and move the original USBridge along.

I never really enjoyed the Explorer² on the original USBridge, I always felt that I could hear distortion on some bass frequencies and the sound just didn’t carry any “weight” but connected to the Sig it was much more enjoyable. I am powering the original by the ALLO supplied PS and an iFi iPower with no mains filtration. I really feel that the Explorer suffers from mains induced EMI/RF and with the Sig this isn’t an issue.

You really can’t fault ALLO on this product especially at this price, the only thing I have seen that might come close is the Stack Audio Link but that is nearly £800.

So you would say it’s better than the SoTM sms200 and Microrendu? Interesting.

Well, I don’t have grounds to make that statement as I haven’t tested either of those products, I was thinking price wise but I guess the Microrendu is around the same price as the Stack Audio Link.

It would be interesting to compare all four of these products.

1 Like

I was in on the first batch shipped to the U.S., and, yes, it was initially set to 220v but performs perfectly with my DigiOne Sig. No hum or buzz, just big and ugly. I bought a second Shanti for my USBridge.


I’m getting a Sig in and already have the USBridge. Plus my current streamer is a Pro-ject S2 Stream Ultra that’s very similar to the Stack. So I’ll be comparing all three but it will be a little while until a review comes out (got a slight backlog at the moment).

Edit - I also have a Shanti to use with the Allo units


That’s great, I look forward to the review @Phil_Wright

My signature has arrived today along with a shanti. I am hearing some light pops over music (using HQ Player upscaling to DSD 256, as I did with the vanilla USBridge). I have dietpi on there right now but I was wondering whether I should try Ropieee or possible a Signalyst NAA driver. Any thoughts? Also, any ideas on the pops?

Hi @tahsu

Have you had a read through this thread

cdsgames is the guy to ask as he designed the USBridge Sig (or he is one of the designers).

I know some of the users were having issues with pops and it was to do with a driver in DietPi, I am pretty sure @spockfish has the correct drivers installed in RoPiee, although I honestly don’t know if it will cure your issue. They were talking about the drivers issues a few pages back from the end, so I got think you would have to trawl through too many pages to find it.

Sorry I can’t be of more help.

Thanks @oneofmany , I have read through that thread recently, but had another look. I see someone ssh’d in to increase the speed but the results were not clear cut. I might give ropiee a go, but not sure if it supports NAA (HQ Player).

Does RoPiee XL support NAA if not make a request to @spockfish for it to be added

Hi Ross, try @jussi_laako’s RPi NAA image

Make sure you choose the latest RPi3 image (360), not RPi4

Thanks @dabassgoesboomboom. I think I will try Jussi’s image first then first. I think the correct file then is naa-360-raspberrypi3.7z. I will report back later on today! Thanks.

1 Like

Yep that’s the one. Hoping it works smoothly for you.

Ha! When does anything ever go smoothly!!

1 Like

Are there any instructions anywhere for this? I flashed the card no problem and wrote the *.img file to the card via etcher. The card is now in the USBridge but I can’t see it via HQ Player. Hmmm.

I tried build 355 and HQ Player would recognise the USB Sig but the music jumps badly. I then had another go with the same 360 image and HQ Player won’t recognise that at all, I have tried redownloading but no dice…

Any thoughts @jussi_laako?

I have no idea about the Allo stuff. I’ve tested the image to work with plain RasPi. And I’ve also tested it with HifiBerry DAC+ board. I also have Digi+, but not as much testing with that one.

P.S. Note that both RasPi images are full 64-bit, unlike most other RasPi OS images or applications.

Ok, thanks Jussi for the clarification.

But the USBridge Signature features the Raspberry CM3 module.

I thought everything compatible with RPi3 is compatible with CM3. Maybe @rahulkc_s can confirm if this is true.?