Allow for more covers and photos setting no longer works after upgrade

Core Machine (Operating system/System info/Roon build number)

Roon 1.7 release 571

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

After upgrade, this setting no longer works…

On what device?

Device is QNAP TS-473. Just tested on my Windows PC and same issue.

I meant what device are you seeing fewer covers on. Have you checked the setting?

Seeing the issue on my windows laptop where I am running Roon Remote. Yes, I have toggled the setting with no effect. Seems to only impact the new Recent Activity >> View All pages. All other views (albums, artists, etc) seem to be ok.

Perhaps it doesn’t work there. Good to be specific as to the problem.

But it used to work there. Problem now is the image are too big.

This is a new feature – it couldn’t have worked in the past. The current (first) implementation is like it is now.

Perhaps I should have been more clear. The original Recently Added section on the Overview page used to show the smaller album covers when I selected View All. Now when I select View All from the Recent Activity > Added page the images are huge.

Yes, but the old implementation (a link to the album browser with according sort order for the recently added) is no more.

It is inconsistent in that recents and releases are large tiles then if you have a streaming service further down it goes back to smaller tiles.

Yes. I see the same inconsistency. I have set the smaller tiles switch and would expect to see that everywhere.

Understood about this being a new implementation. I personally do not like the huge tiles and would rather see more on my screen so I dont have to scroll so much (I know first world problems).

As others already reported, this “View All” isn’t all – it seems to be limited to 100 albums. I would just go to the album browser and set sort order accordingly – so I get exactly what I had before the update.

Hello @tboooe, have you tried reinstalling or trying on a different remote?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.