Allow laptop running Roon core to dis/reconnect from music storage w/o reanalyzing [Solved]

Currently, disconnecting a laptop on which the Roon core is running from an external drive which contains one’s music library prompts Roon to reanalyze every track, over the course of many hours, every time it’s reattached.

A nice improvement would be to adopt iTunes’s behavior; it doesn’t have to do any work when its library is disconnected and reconnected. Ideally, Roon wouldn’t miss a beat when I unplug my laptop from its external storage. If I have to quit Roon before disconnecting and relaunch when connected, that would be fine, too.

(The problem is that even at the Normal setting, Roon uses a lot of CPU to analyze a large library, and the machine gets warm and the fans come on and a lot of power is used.)

1 Like

This is not intended behavior–this sounds like a bug. @vova will be along to help.

Hi chreliot,

I shifted this thread into Support for further attention and investigation.

Hello @chreliot, sorry for troubles here. I need more info to start troubleshooting procedure,so let me ask few questions:

  1. Are you talking about background analysis ?

  2. Does the number of tracks which is shown after the slash is always the same, or it decreases with every reattachment ?

  3. What operating system are you running ?(Windows 7; OSX 10.9; etc)

  4. What version of Roon are you using? (Settings > About)

  5. Tell us more about the laptop you are using (for e.g.: MacBook Pro 2011 w 4gb of RAM)

  6. How your external drive is connected to the laptop

Thank you for following up! I’ve been documenting the analyzing, and the problem seems not to have continued, so no problem for now. To clarify, though:

  1. Yes, the issue was with background analysis.
  2. The number of tracks increased (by thousands), after it had run down to zero, without my having added new music.

I’ll follow up with specific data if the issue recurs. Thanks!

Thanks chreliot,

The next release has some bug fixes that may affect this issue. I’ll mark this thread [Solved] so that it’s not seen as a current issue requiring attention by the devs when browsing Support. Please feel free to either post in this thread again or create a new one should the issue recur.