Allowing incoming TCP ports 9330 to 9332 in the MacOS firewall


When i run sudo ufw allow 9330:9332/tcp : i have command not found, can you help me please.



Mayby your distro uses iptables and not ufw.
If I remember correctly, try
sudo iptables -A INPUT -p tcp –dport 9330:9332 -j ACCEPT
sudo iptables-save > /etc/iptables/rules.v4

Hi Will,

As mentioned by Christophe_Saelens, this means that the ufw firewall is not installed/active on your Linux distribution. There could be different reasons for this:

  • You are using another Linux distribution (Debian, CentOS, …)
  • If using Ubuntu, you might be using another version that uses iptables

If the iptables workaround provided by Chirstophe doesn’t work, please run the command lsb_release -a in the terminal and post the result here.

Thanks Christophe, i have a Mac with my Roon core on it, here the messages when i launch the commands. My Roon remote crashes immediatly when i run it, the same thing on my Iphone 11.

To be fair, I don’t know anything about MacOS. Maybe someone more knowledgeable can chime in?

No problem, thanks Christophe.

Does this replace the rules I already had?

  • 9100:9200/tcp

Many thanks for the solution, I knew it was the firewall but you saved me a morning of figuring out which rule.

Hi Bradley,

Given the Roon team did not share technical information about the use of those new ports, I just left the old rules in place just in case.

1 Like

I’m not familiar with macOS neither.

But if the Roon application crashes immediately on startup, I would say it is unlikely a firewall issue.
Let’s hope someone from the Roon team can assist you.