Am I an Idiot about ARC?

Roon Core Machine


Roon Nucleus +

Networking Gear & Setup Details

FIOS Gateway G100 modem > Bonn 8 Silent Angel switch

Connected Audio Devices

Auralic Aries G2.1
  1. Mola Mola Tambaqui - hardwired ethernet
  2. Mola Mola Makua pre amp with internal Tambaqui DAC hard wired ethernet

Number of Tracks in Library


Description of Issue

My Nucleus+ will not connect as core. I have had continuing issues with needing reboot for the life of my Nucleus. It is two years +. In the past I would often need to reboot. Now, since DEcember update, it will not successfully connect. Issues have been ‘data base corrupted’ or it wont even sign in. I have worked with ROON support for quite a while, but it is very difficult to connect with ROON support in a meaningful and efficient way.
What I am saying is that by the time I get a response and reply, days go by. Or I reply immediately and don’t get a response for days.
Both @beka and Kevin have helped, but I have been asking for help now this time for over a week and NO REPLY.
I was told about a month ago that my Nucleus needed repair and was out of warranty. I sent it back and it was repaired. The SSD was replaced at my cost. When I got it back it was still the same, would not connect and booted me right out of Roon. I restored an older backup and the issues persisted.
Interestingly, as suggested by beka, I removed Core form my Nucleus and installed it on my 2014 Macbook. I used the same backup from December. It works perfectly. I uninstalled Core on this macbook and reinstalled on my repaired Nucleus+ and it would not work. I went back to the old laptop and it works fine. It works wired or even on wifi. My network has been extensively tested and is adequate.

The issue is the Nucleus+.

So how can I get help? I have asked for over a week for a simple and considerate reply and got

I am trying to imagine why Roon support will not respond to me. I am an early subscriber and purchased your high end turnkey devise. It has not performed as expected.

I am fatigued by these long emails and requests to send logs, reinstall, try something else, and it still has not worked. My thread has been made private as I guess it is not good advertising.
I have been patient and done everything asked.

So I ask ROON Support again: Can someone please help me?

I am going to go out on a limb an say no. you’re not.
I am going to ask for a bit more detail on your misunderstanding though.

I love that you filled out the template but failed to ask the question. So refreshing to those who scream the question and provide no detail. :slight_smile:

What is it you would like clarified? Odds are you aren’t alone in your wonder.


Thanks for your kind words Paul, I have updated my 4 endpoints and three remotes and Nucleus+ to 2.0. They all show ARC now is settings. I did the new update today
But when I am away from my home network whether in my car with good (not 5G) reception, or at my office where I have good wifi, it will not connect. My remotes (ipad, Imac, I phone) it says core not found.

You are welcome.
ARC itself will require some setup to get working. I recommend setting up your phone first for ARC. You can remove it from wifi and use a cellular connection. Once you have it connecting switch back.

On your router you will need to enable UPnP or setup a static port forward. How? Is entirely dependent on your FIOS Gateway modem setup.

Page 93 is where you should start.

roon also wrote this to help.

Feel free to ask here as people are mostly willing to help.

When at home and you open the Roon app (not ARC), then navigate to Settings > Roon ARC, do you see any error messages or does it say Ready like in my screenshot?

1 Like

Sorry your question(s) aren’‘t very clear. What does "booted right out of Roon’ mean? Some screenshots will be very helpful.

Are you having an issue with using Roon at home or outside using Roon ARC?

The standard Roon app will not work outside of your home network (unless you are using a VPN to tunnel into your Roon Core). You need to install a new app called “Roon ARC”, which is available only for the iPhone (and iPad), but not iMac.

Now I’m confused. Is the issue with ARC not connecting away from home, or is it about the Nucleus+ not working?

Thank you all. My ipad and iphone seem to have it ready. How do I enable my core (nucleus+)?

My Nucleus and home network works perfectly. Sorry how I miscomveye that; hard to type and watch football!. Here is my screenshot of my core:

Ah, the links MamaTried posted above for setting up Port Forwarding are a good place to start.

Thanks I will get into adjusting the modem tomorrow. Thanks all again!


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.