Amazon Music Autorips and iTunes Match

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue
I have Amazon Music and ITunes with Match on my PC.
I own 1000+ Amazon Autorips, each 25x kB/s MP3.
I downloaded those.
I copy them into my ITunes folder, where I previously downloaded all my bought ITunes song.
ITunes sees the Autorips and adds a AAC (25x KByte/s) copy through the Match process.
I add that folder to Roon, all 5000 tracks get imported.
But now I have most sings twice: once as MP3 from Amazon and twice as AAC from Apple. How do I get Roon to only use the best, which is the AAC version I believe.
What would happen if I rip my CDs and add them as a third version of the same Album/song?

Roon is likely not seeing them as the same version of the song or album if it’s duplicating them. You can group albums together easily enough using the album browser select the albums you want to group as one click on 3 dot menu, choose edit and then choose group alternative versions. They will now be shown as one in Roon, you can then choose which is the primary version to play.

Hi @Joachim_Strobel,

Can you share a screenshot of Settings > Storage?

If you go to Settings > General can you confirm Show Hidden Tracks and Albums is set to No?

… I did set both to yes. Is that a problem?

So there is no way to tell Roon to take the file with the highest sample rate?

Hi @Joachim_Strobel,

If you set this option to No it will hide duplicate albums. They’ll still be in Roon and you can select them from the Versions tab of the main album, but they won’t appear in the main browser pages.

You can set audio type as a label on the thumb nail pictures then select all the ones you dont want visible in roon and select hide. I used this to clean up my library when I first started.


Roon will default to the highest sample rate, but as MP3 and aac are the same sample rate not sure as I don’t know if it chooses via bitrate or format. But for this to work at all you need to have them all as the same album.

Thanks for all the advice. I configured Amazon Music to save all downloads into the iTunes folder a then removed the Amazon music folder from Roon. Apple match replaces then the mp3 from Amazon with an m4a file and I have no duplicates and all is fine. Roon should have an option to exclude certain file types.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.