An audio file is loading slowly. This may indicate a performance or hardware problem.”

Core Machine (Operating system/System info/Roon build number)
Roon Core Latest Build Update [Roon 1.7 (Build 537)]** : Lenovo 80NV (Y700 Gaming Laptop Model) | Windows 10 | CPU: Intel Core i7-6700HQ (1 CPU, 4 cores, 8 threads Base clock 2.6 GHz) | SSD: Samsung PM961 NVMe PCIe M.2 256GB (148GB free [System drive] Max speed: PCIe 5,000 MB/s SusWrite @10s intervals: 427 318 323 322 321 310 MB/s)| SSD: Sandisk S-1T00 1TB (260GB free SusWrite @10s intervals: 314 376 403 394 381 398 MB/s) | RAM: Ramaxel 2x8GB (16GB SODIMM DDR4 clocked @ 2133 MHz Running Roon: 12.1 GB free) | Ethernet cabled physically to Amplifi network core wifi router
Library Storage: Core of collection Exact Audio Copy Lossless FLAC CD-Rips | 630Gb 42,230 tracks 50,280 files 4,126 folders | Currently: Internal 1Tb SSD Drive | Previously: Synology | Prior to Previously: External USB SSD Drive and OS Drive | Prior to Prior to Previously: Synology | No Streaming Services

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Network Core : AmpliFi Router HD with 1 Wireless Mesh Point | version 3.3.0 wifi 2.4/5.0GHz with ~12 devices connected | Commercial supported Internet ISP: 70Mbps Down and 26Mbps Up Ping 13ms typical
Synology NAS : DS215j 2-bay, no wireless, ethernet connected to Amplifi network | MARVELL Armada 375 88F6720 cpu:800MHz 2 cores 512 MBDSM 6.2.2-24922 Update 4 Dual 3Tb HDisks RAID at 79% storage utilized (Old Logitech Media Server Stopped)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Audio Devices Sync’d in one Zone :

  • HiFiBerry3Dac+ - Raspberry 3+ with HifiBerry Hat on 8Gb OS Chip connected to Roon Via Amplifi Mesh WiFi and then wire cabled to a Bose Radio for output
  • HiFiBerry3Digi+ – Via WiFi Optical SPDIF connected to a Schiit Bifrost DAC to a (old) McIntosh Player and Canton Speakers
    Audio Device / Controllers w/ Local output and no Zones
  • Huawei M5 Tablet – Via WiFi and then via Bluetooth to Jabra 65 in-ear speakers or built-in speakers
  • Huawei Mate 7 Phone – Via Wifi headphone jack cabled to a JBL Flip 3 Speaker
  • Apple iPhone 6s – Via WiFi to local system output

Description Of Issue

Since migrating from Roon and Logitech Media Server to Roon-Ready HifiBerry (perceived marked improvement in sound quality) I experience continuous playback problems on all Roon players (HiFiBerry attached playback devices and Android devices).

Roon Public Radio frequently stops with error message “Unable to play this station. Its address may have changed, or it may be temporarily unavailable.”, and must be restarted frequently enough to be un-playable.

On playing music from Core all the controllers regularly get music track, errors “An audio file is loading slowly. This may indicate a performance or hardware problem.” and skips to the next track.

I hope you can help. In the last weeks I have:

  1. rebooted entirety of systems/networks innumerable times,
  2. moved library from Synology NAS to USB SSD drives,
  3. moved the Core from an older Dell laptop on WiFi to a stripped down dedicated Lenovo Gaming Laptop with 16Gb Ram and ethernet cables to Network
  4. moved library from USB drives to newly purchased internal 1Tb SSD drive,
  5. benchmarked PC and updated bios/drivers/etc to ensure optimal dedicated operation (disabled local Music Folder)
  6. moved library back to Synology (disabled local 1Tb SSD Storage)
  7. pruned old music files, cleaned Library, Audio Analysis scanned all tracks (on each move), set On-Demand Audio Analysis Speed to High, removed all ‘skipped’ or corrupted files identified
  8. disabled all other music sources on HifiBerry Device configuration (unused: Airplay, DLNA, Bluetooth, Radio, Snapcast, Squeezlite, Spotify Connect)
  9. Moved music library back to the local drive, and the problem persists…
    Ideas for going forward:
  10. Try to bypass WiFi with test cable across living room floor (am married, this will not last ) and disable Zones
  11. Move all Roon Devices to dedicated wifi Network (unusable laptop controllers, meh)
  12. On Order is a Raspberry Pi Zero for the Digi+ connector, if it works may try others
  13. Replace older Raspberry Pi with new Model 4’s (not like to as 4’s reported to run hot)
  14. Go back to Squeezelite and Max2Play <?> (not wish to do this!)

Any ideas really very much appreciated, have searched extensively online and do not find more ideas to try… and am out of ideas …

Hi @rufous_lechat,

Please accept our sincere apologies for the lack of response here! It looks like your post slipped by us, and we apologize for this!

We can definitely help to get things running here properly for you! Looking at your setup, I’d like to start by trying to simplify things as much as possible so we can understand if things work in the simplest setup — If you play local files stored directly on the Core machine, and you play this to System Output of the Core machine, do things work for you? What about Internet Radio or streaming content to System Output?

If you are able to modify the DNS server addresses in your router try and move the address from the ISP DNS to cloudflare or Google DNS. Roon hammers multiple servers.

You mentioned a pi zero…that won’t run roon bridge as it’s os is not up to it. Pi 3b is a better bet

When you get the slow loading errors what is the signal path indicating?

I would say limit all your WiFi endpoints to 24/48 or max 24/96

thanks Dylan. apologies this side as well. have been tinkering and reading here and trying to fix myself for weeks now. household is fed up with my head in the music PC cupboard (and my mutterings as i bash about in various systems). need to table this for a while. will try and pick it up again later and perhaps we can discuss going through some troubleshooting sequences …
thnks Ged, indeed i never tried messing with ISP side of equation as without streaming i was thinking all locally for solutions (did try a Tidal subscription for a week, it also error-ed out, so has been cancelled as well). will add to a growinf list of ideas when can come back to it.
wizardofoz, indeed, i should have looked closer, as I borrowed the pi-3s, will leave them in place and use the zero for other tinkering… nothing going to waste if can help it!
all the best!


Hi @rufous_lechat,

When you’re ready to pick this back up, just let us know and we can certainly provide further troubleshooting suggestions!

As Ged mentioned, it sounds like you might be running into a DNS issue or a general networking issue, I would start off with @dylan’s suggestion of trying System Output on the Core itself, and afterwards we can add more complexity in with your other endpoints.

As for the networking side of things, I would also make sure that the Amplfi router is up-to-date on the latest firmware.

Have you tried putting your ISP’s Modem/Router into Bridge Mode or Pass Through mode if that is an option? Having the ISP’s device as a Router serves no useful purpose or if there is the option of having a modem only device for your ISP. Having two routers or Double NAT can be a recipe for headaches.

placed my personal router’s DNS to Cloudflair’s and, seemed to cause internal instability for a while, but all settled down , but eventually no seeming impact and no difference in ISP performance or multiple ping plotter traceroutes aor ISP speed tests … however have kept these settings and not reverted them in the hopes there may be residual long-term benefits to not using my ISP’s. however will be looking for a non-US privacy conscious DNS service, thanks for suggestion as have been meaning to look at a proper paid service eventually …

Thanks @Robert_Suryan1. indeed the ISP’s router is blocked to me. With my commercial service contracts they drop a four-port wifi router via DSL in. Their box is crud. and they have a cute habit of sharing out their wifi with others as everyone is assumed to have signed up to their country-wide wifi-domestic hotspot program (it is -their- internet connection, not mine, no lingering resentment here, of course :slight_smile: ). Therefore I connect my wifi router to it with everything behind my equipment. I treat their NAT space as another part of the untrusted internet and a useless extra hop. I have nothing connected to their wifi or to their ports other than my router. (I’ve removed my own BBox firewall, and prior to this a ubiquiti firewall for the time). However, i use no services in their IP space, never connect to their wifi, and etc. I do not bridge my own equipment to their IP space (shudder!) … as i read the article, it seems the double-NAT problem occurs when you have actually placed something on the ISP’s network as well as your own and expect the devices on the different networks to chat back and forth? not the case here. I could, theoretically, break into their box and muck around, but would hesitate to do this without a concrete reason and proof it would fix a problem, and the fix would be stable. And not cause the poor technician a headache the next time I have to call her out. I do have a 2-hour on-site technician contract. They are very sweet and responsive. And most of them actually very good and very patient. and in the end, every two years like clockwork, they have to give me a new box as the old one seems to melt under natural causes. This always seems to be Sunday night at 8 p.m. and the dears never blink. I really do feel affection for the on-site folks and try and respect the boundaries of ‘my problems’ and ‘their problems’ and we get along well. Would prefer not to add myself to their problems or the demise of a router via ‘natural cause’ list. Officially they do not recognize anything beyond their box (is actually an improvement, they used to forbid clients having more than one user-OS end-point device connected!). Ever since they were hacked by the US and the British they treat everyone as hostile (read Belgacom hack on the Intercept if you want a fun rundown) :

As a small mention, i do not stream. All my devices only connect to my 130 space. all my devices are identifiable and controllable via my amplifi router interface. I consider only certain trusted devices to be allowed on the internet and prefer to keep any ‘dumb’ devices (aka, ones I am not controlling, e.g. roon end-points ) disconnected from the internet as a default unless manually checking for firmware updates, troubleshooting, or have a concrete reason to let them speak outside. most dumb devices have no business chatting to the internet, but otherwise I allow them unfettered internal accesses at the moment. Was considering setting up a dedicated ‘guest’ network for Roon alone, or even a standalone wifi network totally unconnected, but part of attraction is using domestic browsing PC to be a Roon controller so did not take this step.
They all self-report being on ‘my’ 130 IP space (255.255.2555.0). So am not seeing how a double-NAT or even the ISP’s ‘useless’ extra router-hop is interfering?
Thanks again and let me know if I miss something?

Provisionally ‘solved’ … provisionally as after-change ran two-days no recurrence, reset to previous-state and error recurred after 1.5 days. Now reset to ‘fixed’ state and waiting to see if recurs …
Attribution: End-Point Network Dissimilarity: using two raspberry pi 3’s, but one is earlier single-band model and sees only 2.4ghz wifi in the mesh wifi, other is dual - band sees and defaults to 5ghz mesh access.
Fix: Set wifi router to display both frequency, disconnect faster pi from 5ghz network and force it to slower 2.4ghz so they are on same frequency <possible root cause, does Roon depend on network for internal sync/clock settings or something? would be OK on all-fiber or all ethernet systems, and maybe explain why everyone says ‘mesh’ to be avoided>
Confuse-a-Cat/Red Herring: network errors occur even when -not- using berry devices in playback or grouped mode? Error message re-occured when not stress testing and using only android end-point in mini office. Also problem remained when using wired access to single (slower) access point and de-grouped as per normal test protocols … <Roon is unhappy with dissimilar networks end-point access even when not playing to devices?>
Validation Attempts: Playing all end-points at same time from different sources and trying to load core with heaviest lossless files, playing radio and etc … time as this issue does not recur immediately …

1 Like

Hi @rufous_lechat,

I wanted to check in with you here, has the issue stopped occurring since you made the previous change?

I was looking over your previous post and I didn’t see any mention of you testing the System Output zone on your Core, is that working as expected?

I would first focus on getting System Output to play as expected with no issues and then we can add complexity back in with the Pi(s).

thanks @noris, will tear system down and set to running a few days in standalone and look for any traces of issues in System Output mode only as you mention … can you point me to any a log file I can search for the error in opposition to looking through a few days of queue play (will not be listening to system output myself! :slight_smile:

Hello @rufous_lechat,

You can access Roon logs by using these instructions. I would take a look for any “Dropout” traces or the buffer falling towards 0% before the end of the track (it is expected for buffering to go towards 0% when you are at the very end of the track, but not before). If you don’t see anything obvious in the logs, just let me know and I can also check the log for you.