An issue in the very beginning

Hi there,

Activated a trial period for 14 days two days ago. I am getting down to business of Roon Rock preparation on NUCi7BEH (SSD Samsung Evo Plus 250 Gb and 16 Gb (2 pcs per 8 Gb) Memory). No OS, just wanted to install ROCK.

First activation of NUC - no bootable drives detected. No drives in UEFI (just 2 LANs are being displayed) and as well in Legacy. Legacy Boot is checked - “No Boot Drive”.

But in PCI and SATA sections the Samsung EVO is listed.

Pls do tell me what is up? I updated BIOS firmware to the latest version (0085). I have been already getting the same picture for 2 days. .

No USB flash drive is being detected too (UEFI/Legacy), but F7 is active and I succeeded to update BIOS version via USB-flash drive.

Hope you have experience like that in similar issues. What shall I do in order to clarify the situation - to figure out what unit/component is in malfunction or something else?

Thanks a lot in advance.

S

Don’t know what the problem might be. There’s a lot of info to search on this forum

You don’t need ROCK to test Roon.

If you have another PC or Mac, I would advise installing there, just for the trial and worry about ROCK later.

1 Like

No need to test…I have got some experience with Roon (Windows 10)…It is my first NUC. Would be obliged to somebody who faced with the same and solved this successfully.

Does this thread help at all?

Have you actually loaded ROCK on the machine and got the right responses yet? If so it should be a matter of putting legacy boot on and arranging the boot priority.

Thanks…went through the links suggested. Unfortunately, has nothing to do with my issue. The latest version of BIOS set up “Legacy S3 Standby” instead of “Modern Standby”… In my NUC UEFI and Legacy are both active and may be checked both together and as wel separately.

Thanks all the same

Not yet…Since Legacy shows me nothing, I am not able to set priority to SSD and start ROCK installation…

You probably know this, but you want to set priority to USB not SSD.

The key for me was turning off secure boot.

Roon needs to update the ROCK document to explain that updating the BIOS probably isn’t necessary.

1 Like

Yes, I do and tried this too…thanks…

I was doing all the procedure step by step - switching on - BIOS update to latest version - burning ROCK image - and nothing else longer so far…

I suppose that I have tried everything possible for the very two days what one may find through Internet.This community was the last hope. I think it is time to test SSD and NUC itself for physical malfunctions…

Thanks so much for everyone who replied

I don’t think you have physical malfunctions unless you have fitted your M.2 card incorrectly. (Been there, done that!)
I have had issues with some boards trying to figure out the right settings to make everything visible. Before giving up try resetting the bios and going from there. And as stated concentrate on getting your USB drive with ROCK booted. If everything is OK it will show you available drives for install. If not it will say they are not there and you can take the next step.

Noted, thanks. Will take this into account.

Honestly, I have an inner feeling that it is okay from a technical point of view the stuff concerned and I would be glad to get assured in this. But of course, I may be wrong… I will for sure be back with a positive result, if it happens.

Succeeded…

First of all, I would like to acknowledge all for the replies in my thread and would like to emphasize I really appreciate your sincere intention to help. Thanks.

30 minutes later after I have placed my latest post, I made up my mind to start from the very beginning - reboot BIOS by means of Power Button Menu - carefully went through all the available instructions of ROCK inastallation (roonlabs, compteraudiophile, etc.) - checked/uncheked all needful items in BIOS - rebooting - and at last I saw the desiarble message on the display - Legacy shows me Samsung SSD and USB flash drive with a ROCK image burned. Very fast installation and through web I am staring at the menu of ROCK…

Some question, if you do mind:

  1. Does it make a sense to power NUC with LPS (as an example HDPLEX 200) , if a RoonBridge device or a Roon Ready unit are going to be used? No any direct USB connection to the ROCK Core…

  2. At present the chain of connection looks like as follows: router - switch - NUC- bridge (connected via the switch too).
    Will be: router - switch - NUC - bridge. NUC is wired to the switch though an USB-Ethernet adaptor. NUC to the bridge via thier own LAN-sockets, directly. Cons/pros concerning the both variants?

  3. I have noticed that percentage of the section “Roon Database& Settings” may be variable from time to time - 99% or 100%? What does it stand for?

Thanks.

S

I wish I had categorical insight.

I have a fairly complex home network with a core switch in the laundry room in the basement, five access points inside & 2 outside, and two subsidiary switches. They’re all unifi gigabit gear.

The best set up for me is to have the ROCK NUC in the server “closet” plugged into the core switch. My NAS is also there and plugged into the switch. My endpoints (mix of Sonos and RopieeeXLs) are scattered around. I think that the size of the streams are such that it is unlikely to matter unless you are running multiple streams across a 100Mbps network and doing big file transfers simultaneously, but I could be wrong. However, if you have a complex topology, locating the ROCK and your NAS close to the core seems like a wise move.

Hope that helps, and glad you found your way out of the mess as I finally did!

The 250 GB Samsung drive you installed Roon Rock on does not actually have 250 GB. It actually starts out with around 227-230GB. So, after Roon Rock OS is installed (which is very small), you have 227 GB of free space left on that drive. Your Roon database and saved settings are also saved to that drive, but they are only using less than 1% of that free 227 GB, so it is telling you that you have 99-100% of the original 227 GB free .

In terms of a LPS for the NUC, you are not going to get a straight answer. A debate will open up and you will have people on both sides of the power supply debate. I would say find one for your NUC and buy it and test it to see if YOU hear a difference. If you don’t, then return it. Every person’s set up will give different results.

For your router, switch and NUC connection you don’t need to buy a USB to ethernet converter to give you an extra port. The nucleus only has one ethernet port, so run that to the switch. Take the bridge and also plug it into the switch. Now both of these devices will be connected to the internet and to each other.

I hope that helps a little but!

Just to expand upon what Animal said. The OS drive of the ROCK cannot be used for anything else. So, you do have a lot of space left on that drive, but, you are not able to use it for anything else.

Thanks for the profound reply. Quite understand your attitude to the ROCK system building within home. In addition to, I share it completely…

It stands to reason, NUC is being placed in another location as to a RoonBridge unit (currently Windows 10 laptop) or a RoonReady device of possible in future. Router -switch - NUC - NAS: one location, the bridge - another one. Multiple zones - I am afraid - it is not my case. My next to kins are not inclined to audiophile addiction, they are satisfied with Airplay transmission and WIFI connection. Moreover, my main system is a headphone rig system.

Thanks for wishes and advices rooted from your own experince, It is really valuable…

S

Thanks for clarification. Now it is clear…Is it possible that ROCK system consumption will be more that 1% and what it does mean in this case?

Noted as to LPS, I see. I have got HDPLEX 200 (an ollder version), I like it. I will for sure run some tests, planning to use it as a power source for the switch, NUC and NAS as well…

My question, in connection with NUC powering by LPS, has a lot to do with a widespread opinion that no need to implement LPS, if NUC is not being used in direct USB connection with DAC/streamer.