Analysing stuck

Hi guys.

In settings, my analysing shows as stuck on something in the last remaining tracks (currently 2/10). This has been going on since the outset - I guess there’s something in there Roon doesn’t like but it just won’t give up. It’s been over a month now so I’d love to clear it somehow - can you help?



Have you looked at the Roon log files to help identify which audio file it is hanging on?

Sometimes performing say a FLAC to FLAC re-transcoding with dBpoweramp can help.

There’s a thread around here somewhere on this that I cannot find. But the bottom line is that this appears to be a bug that can be cleared up by changing your analysis speed to “off”, then changing to back to “fast” or “normal”.

I agree with Carl, looking at your logs should be the first thing.

Had this problem with the stuck analysis too. “Clean Up Library” was the remedy. Maybe roon tried to analyse a file that simply wasn’t there anymore. Nothing to see about in the log.

The “Clean Up” did not help as long as I thought it would. Analysing has stopped again :worried:

Thanks @Carl. Where are the logs on OSX?

It might be an idea to have Roon give up on a file and skip over it (maybe even notify the user), if it hasn’t managed to get past it in, say, 8 weeks :wink:


Have the same issue on Roon Server on Linux (Ubuntu server, Intel NUC, Synology Nas, all wired gigabit)

Any solutions to this? It seems to be among the last 40 files or so of totalt about 30.000.

Tried reboot, stop/start background analyses.

Everything else works great!

(Mine are still stuck…;))