Android 1.8 app and album covers (memory leak?) [Solved: Reboot]

After I use Roon for a few sessions on my Samsung Galaxy Tab S2 9.7 tablet, the album covers stop displaying. This can be fixed by rebooting the tablet.

I do not have this issue when using OpenHome, with either the Lumin app or BubbleUPnP. Nor do I have a problem using Roon Control 1.8 on my Windows machine, nor does the tablet have similar trouble with any other software.

This leads me to suspect a memory leak in the Roon app.

P.S. The Core is ROCK running on an i7 NUC. Music files are on a Synology NAS. The renderer is an Auralic Aries G1.

Hi Mike I saw that a time ago, but not with the recent updates.
Have you looked at the size of the cache within the Samsung Settings. It might be worth trying to remove the cache and see if that helps.

I know that there were a lot of initial instabilities on 1.8 but it did get much better.
I use a OnePlus 9 pro and that has worked great since I had it, but the OnePlus 8 and 7 pro also work well.

My pixel C tablet was an absolute dog though as it didn’t seem to have enough memory for Roon to work well.

Hi Mike,

Just another view…

Tab s2 9.7 and my album covers are working fine, has been for years, so I am not so sure about it being a Roon only issue. I run against both a ROCK and Windows Cores, both stable and displaying art for each. I am using a single AP and not a mesh network. My files are local to each Core.

Thanks, Michael and Daniel.

I deleted the cache and will see if it makes a difference going forward. I am not sure why I have the problem, since DB does not, but the tablet does run fine with all other apps. I hesitate to replace it, as Roon is its main use, and a better tablet is not cheap. It’s not just the money – I prefer to use things as long as reasonably possiblel.

Perhaps the cache clear will do the trick. If not, I’ll post again.

P.S. There is a big, and almost empty, SD card in the tablet, but I didn’t see an option to tell Roon to use it. Did I overlook something?

Mike I don’t think Roon can use the micro SD card. Also it’s not a good place to put highly changing files on SD, much better for music and photos.

Let us know if clearing the cache works.
Finally make sure you have yesterday’s update installed.

Yes, yesterday’s update is installed, so I’ll hope for the best.

Something is going on in my setup. Both the tablet noted and a cell phone (LG V20) exhibit this issue – not displaying album art, or at least not displaying it for most albums. Oddly, if I quit the app and re-open it, often the album art appears immediately.

Could the issue involve these being “older” devices – I put that in quotes because I don’t consider things aged 3 or 4 years to be “old,” but in the tech world, 5 minutes can be “old.” Is Roon routinely tested on Android 7 and 8?

This issue does not occur on Roon Remote running on a Windows 10 computer (and using the same Core).

I have latest Roon releases on all devices. The Roon Core is on a highly over-speced NUC connected through a managed switch to my router – the NUC is assigned high priority on the network.

When Roon won’t display an album’s art, I can open the Qobuz app on the same device, and there it is.

What is causing this? How can it be remedied?

Mike not sure about this one, I saw some older complaints including I think from @ogdens_sliced, but I thought these were resolved by a new Android version some time ago. I certainly had some issues with my Android 8 tablet, but I am away now so cannot charge it up and test it

We can tag @support on this but they will not pick it up until next week.

Do you have any other devices in the house you can test it with (tablet or other phone’s) and see if it happens from those as well.

Edit: Mike I have just moved this thread to the support section for you. I had no idea I could do that :grin:

Quite possibly this is a memory usage problem, that is building up over time.
Try to uninstall & re-install the app(s).
Good chance your issue is solved (for some pdriod)

@Michael_Harris - Thanks for tagging @support and moving the thread. Those are the only two Android devices I have ready access to. But two says a lot more than one, no?

Yes that is true, but it would be great if you had an iPhone or iPad to compare the results from the Android devices.

Hopefully someone will be able to pick it up and help you over the next couple of days.
Good luck with resolving it Mike

The major android issue shortly after 1.8 was the big freeze issue.
That was fixed a couple of months back in an app update and, for our house, the issue hasn’t reappeared.

I did have a minor issue a while back where album art was not showing.

A system wide reboot of network, core and control points cured that problem.

1 Like

Hey @Mike-48,

Thanks a bunch for engaging on the Roon community to find a solution to the missing album covers. We’re sorry about the trouble :sweat:

We’d love to help, so I’ve looped in our technical team so they can take a closer look at what might be happening.

Please, sit tight :pray:

Hey @beka,

Thanks for your post. After reading the post by @ogdens_sliced, I rebooted the Core to see if that would make a difference. I’m happy to say, it appears to have solved the problem. It’s not clear why a reboot should be necessary, but if course, it’s not difficult to do, nor time-consuming.

If I run into the issue again, I will wrote more. Thanks to all who replied!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Roon Core Machine

Core is ROCK on new i7 NUC

Networking Gear & Setup Details

ASUS RT-88U router
TP-Link T1600G-28TS switch

Connected Audio Devices

Ethernet: Auralic Aries G1
control via Android 8 and 7, latest app versions

Library Size

Apx 45,000 local tracks + Qobuz

Description of Issue


After using the Android app a few times, album art does not load. This was described (by me) in a recent thread. I thought it was fixed by a reboot of the core, but it was not, as it occurred again last night.

Often, closing and restarting the app on the tablet or phone will fix the problem temporarily.

My report of a fix was premature.

Hey @Mike-48,

I am sorry about that, but very thankful you let us know. I’ve reopened your initial thread and added your most recent post here.

Definitely, we need our technical team to help. Stay tuned, please. They return to work on Monday.

1 Like

Hi @Mike-48

I’m sorry to say that we missed that this topic was re-opened.

Are you still seeing this issue occur? Do you see this happen when using any other remotes?

Hi @dylan, and thanks for the post.

For whatever reason, I have not seen the issue lately. Maybe the latest update? Or something to do with caching?

I never saw this on the Windows remote, and I don’t think I saw it on the cut-down version of the Android remote that runs on phones.

I should add, I recently had Comcast out to improve our cable connection. Since many of the album covers in question are local files, it seems unlikely to me that their work improved the situation – but computer software is surprisingly unpredictable.

1 Like