Android 10 and cannot connect

Ever since my phone updated to Android 10, I need to reboot the phone to get the roon app to connect.

Hi,

I’ve moved your topic to the support section of the forum.
In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Hi @Benson_Margulies,

Does force-quitting the Roon app and opening it up again also allow re-connection?

Please do share the full setup details as @carl suggest as that would help us better understand the setup:

A Mac mini is the core. WiFi is a Netgear. Everything was fine until a recent phone upgrade to Android 10. Force quitting the app is not helpful. Every time I have to say ‘look for another core’ and then reboot.

Try deinstalling and reinstalling the app.

No joy. Uninstalled, reinstalled, and it cannot see the core.

Hi @Benson_Margulies,

If you click on the “Help” button that appears after 60 seconds on the “Choose your Core” screen, are you able to manually specify the IP address of you Core and perform a manual connection?

Feeding in the IP address works.

1 Like

Hi @Benson_Margulies,

Thanks for letting us know the manual IP works! Do you by any chance have an “IGMP Snooping” or “IGMP Proxying” setting on your router?

We have seen that sometimes routers do not pass multicast traffic through properly and those settings may help.

I do not think so. In any case all is well on my wife’s phone which is still on a slightly older android version.

I had issues when I had Netgear router and my Galaxy 6 phone. When I ditched the Netgear for wireless and used something else it worked. There is definitely something about how some Android phones and versions work on wireless with Netgear products and Roon. This was on Android 7 at the time. I have had 2 differmet Android phones in this time and not experienced the issue again. Current one is a Pixel 4 on Android 10.

This is the official Roon support forum. I expect to get help from Roon employees who understand the process of diagnosing software defects. When I report that precisely one thing changed, and one thing broke, I expect some focused attention on that one thing. The idea that Netgear routers in general (as opposed to some particular version of the software on some particular model of router) somehow gum up the mDNS lookup for the Roon app on my phone frankly beggars my imagination.

Pretty clearly, Roon on Android 10 is/was having an mDNS problem. Nothing else in my house is having such a problem. I can fire up a Chrome extension that does mDNS on my chromebook, and resolve puck.local just fine.

As of this evening, things seem to have improved. It takes a long time, but Roon finds the core. So we might be done here.

Hi @Benson_Margulies,

Yes, I understand that the only aspect you changed here was Android 10, but what we have found is that this issue is often environmental, meaning multicast wasn’t’ working properly before you upgraded to Android 10 as well.

Android 10 is more restrictive of the multicast features it supports (you can read a thread here for more information).

We have staff members running Android Roon Remotes, and on a properly functioning network they are not seeing any connection issues, so I would take a look at the multicast setup on your end.

You could also try using the Multicast Broadcast IP of 255.255.255.255 and that might help, but ultimately you’ll want to check the router.