Android App Crash And Hang

I have 3 android devices and the Roon app has not worked properly on any since the 1.8 roll out.

It constantly hangs and crashes on startup.

Makes Roon a pain to use these days and in all honesty it is unacceptable that a key element of the user experience is utter junk this long after 1.8 hit the streets.



Hello @ogdens_sliced ,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does the app crash when you perform a specific action or navigate to a specific tab in the Roon app? Is there any change in behavior with an app reinstall?

1 Like

I’ve had the odd quirk with Android devices. Have you tried clearing App Data/App Cache and disabling battery optimisation for the Roon App? Worst case, have you tried uninstaling/reinstalling?

Yes tried all that plus additional.
Have raised a new ticket, see what happens.
From seeing the issue raised on these boards a number of times, there appears to be some issue with Huawei and the Android app for 1.8 control. Also with Samsung but to a lesser extent.

12 posts were merged into an existing topic: Roon 1.8 Android hands and have to force close app [Investigating]

I did as you requested and raised a support ticket.
A moderator then merged that thread back into this thread and then closed the ticket.
It also states “Solution” on the posts in this thread.

So, please share what the solution is?

As stated in the ticket you asked me to raise - the problem continues as it always has.

@support #support


1 Like

Hi just adding some clarity on this …

You were asked to provide additional info, but it was not necessary to create a new topic. Hence the merge back into your original support request, so all the history is together which aids Roon’s @support team.

For what I can see, your support topic is still open and has not been marked as solved. Thus I’m sure after the weekend @dylan will follow up on the additional information you have kindly provided.