Android App Disconnecting [Resolved]

Please update your android app. It disconnects constantly and it requires a reboot of the phone every time to reconnect.
I rather see it off the play store than have to deal with this bugs!

@Fernando_Fuentes Whilst I am sure you are frustrated maybe a more constructive approach would first be to ask if you are the only one affected and if you are then start a new thread in the support section.

A similar approach and a little less attitude in this post might help too.

Static ip via dhcp?



I’ve had major bugs (now fixed or worked around) on Linux and MacOS, but the Android app has worked well all along. There are lots of Android versions around, but my Nexus and Pixel devices are always on the latest Android version. Maybe that makes a difference.

it’s called sticky dhcp.

There is no attitude. The android app just has major issues. I have several Android phones with several versions and have the same issue. All my iPad or iPhone’s have non.

For you in your environment; other people have had the exact opposite experience with Android endpoints.

If there is a request for support, then the thread should be in the support section. I will move this thread over to that section and ping support for their input. @Eric

1 Like

Thanks for the correction.

Hi @Fernando_Fuentes ----- Thank you for the report and the feedback. To help me evaluate what could be causing this issue with your Android device(s), may I kindly ask you to please describe your network configuration/topology, as well as providing insight into any networking hardware you are implementing.



Thank you for your prompt response.

I have about 7 android devices. All connected to OpenMesh AP’s.
One MR1750and two OM5P-AC.
Application Layer reporting is turn off.

DHCP Is provided by a pfsense firewall.

As soon as I get home ill post all of my phones and their respective OS.

Thanks @Fernando_Fuentes – any chance you have a standard DHCP router around you can test with temporarily?

If you’re able to plug your Core into that router and confirm whether the performance from your Android devices improves, at least we’ll know whether the OpenMesh AP’s are why you’re seeing different performance from others using Roon with Android.

That will be a good first step towards getting this resolved for you, so thanks in advance for your help troubleshooting this.


Your request does not make sense. Can you help me understand?

My Core is connected to a Layer 2 Switch, My AP’s are connected to the same switch… Why would changing my core to a router would make a difference?

What are you trying to narrow down? Wireless? Would changing my AP make more sense than changing my router? Or are you after my DHCP leases? I can stand a temp DHCP server…

I have a L3 Switch that I can stand up for routing if you are convince that is a routing issue.

Thanks for your help!

I’m trying to confirm whether the mesh network is related to the issue you’re describing, which sounds like the symptoms I’d expect if the Android devices are having trouble maintaining a stable connection to your Core.

It would be helpful if we knew all the basics of your setup, but based on what I know right now, the most obvious difference between your setup and other, more stable setups is the OpenMesh network.

From what I can tell, this is the first time these devices have been mentioned on our community site, and it’s possible we’re interacting badly with them – this could be a Roon bug, or a bug in the OpenMesh devices, or it could be completely unrelated, but the easiest way to confirm that would be to set up your Core connected to a basic DHCP wifi router and try connecting via one of the Android devices.

If that configuration is more stable, at least we know the OpenMesh network is related to your issue. If the problem persists, we need to look elsewhere, like your Core, your Android devices, etc.

Again this is just a simple first step towards understanding why your setup is experiencing this issue. In any event, the details of your setup would be helpful here, and then we can move forward from there.


I understand loud and clear.
Thanks for helping me. I will be posting the requested information as soon as I get home.

@mike and @Eric

  • what version of Roon you are running (Settings > About; If you’re running Windows, please let us know whether you’re running 32bit or 64 bit)

Phone: 1.3 build 209 stable 32Bit.
Core: 1.3 build 209 stable 64Bit.

  • What operating system you are running (Windows 7; OSX 10.9; etc)

Debian Jessy 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1 (2016-12-30) x86_64 GNU/Linux

  • Basic information about the device you’re using (MacBook Pro 2011 w 4gb of RAM; HP Envy laptop w i7; etc).

EVAG Mini ITX Water cooled self built Server:
AsRock WS Mini ITX DDR3 1600 LGA 1150 E3C226D2I
16GB Kingston Technology HyperX 16 GB Kit (2x8 GB) 1600MHz DDR3L PC3-12800 Non-ECC CL10 DIMM 1.35V Low Voltage XMP Desktop Memory KHX16LC10K2/16X
Intel® Core™ i5-4590 CPU @ 3.30GHz

  • Describe where your music is stored – this includes hard drive description and interface type (USB, Firewire, etc. If you are using a NAS or any other kind of network storage, be sure to include the information requested in the Network section below)

MiniPro 1TB External eSATA 6Gb/s, USB 3.1 Portable Solid State Drive SSD
Its connected to the server via USB 3.0.

  • Let us know your collection size (approximate number of tracks)
    Roughly around 1.2K

Going back to my network…

As mentioned I use OpenMesh AP’s One MR1750and two OM5P-AC.
They connect down to my L3 Switch (Extreme x460-48P) which is acting as a L2. All features are disable. The MR1750 gets PoE via the switch and the the OM5P-AC’s are bricked powered.

There is an up-link to another L2 Switch that connects my Server and other devices to the network. Simple L2 Netgear Switch.

All of the devices get lease via DHCP from the pfSense Firewall.

My Mobile devices:

1 LG V10 - Marshmellow
1 Motorola - Marshmellow
1 One Plus One - OxygenOS Marshmellow base
1 One Plus Two - OxygenOS Nougat Base
1 Galaxay S6 - Marshmellow
1 nvidia Shield Tables - Nougat
1 Google Nexus 7 - Marshmellow
1 iPhone 5S iOS 9
1 iPhone 4 iOS 9

To the details:
So an interesting point you made @mike was that you dont know if Meshing plays well with roon and android…
All of my android devices had major issues with roon and as soon as you explain to me what you where trying to rule out it made sense to me… So I went and disconnected my Meshed AP’s and let my MR1750 which is my gateway and is hardwired be aloned on GW mode and no Mesh…

I did this last night when I got home. Sense than none of my android using roon have had any crashes or problems…
Roon has been solid…

Which brings me to ruling that roon does have issues when its hopping AP’s even though is “Seamless”… Well maybe not issues but it is sensitive to it… It does not like the hand-off from one AP to the other…
The question remain is should it be so sensitive? Should it care that is been handed-off from one AP to the other?

Out of all of my music applications none had issues with this, And if I may say, This is not exclusive to meshing nor openmesh AP’s. I am sure that others have this type of setup they just don’t know that is a mesh…

My main issue here is the hard crash the roon on android has. It will not connect to the core… Not even if I kill the app from the app manager. I actually have to reboot the phones or tablets…

Interesting note: My iPhones do not have this issue… I can go around my house with my iPhone and use roon with no problem…

Thoughts? Ideas?
All are welcome :slight_smile:

Thanks in advance!

Hi @Fernando_Fuentes ---- Thank you for the follow up. I would like to grab a set of logs from you and will be contacting you via PM momentarily with instructions.



Will await instructions.

Thanks again!

1 Like


PM Replied and logs sent.

Thanks for all your help and attention.

1 Like

Thanks @Tech_Whisky_Lab for your update! The resolve to this issue can be found here:

1 Like