Android app fails to start on Huawei Nova 5T

Description Of Issue

My Android app on Huawei Nova 5T fails to start roughly 50% of the time. It hangs on the black startup screen with the Roon logo. This happens irrespective if I am on Wifi or Cellular. When it successfully starts, it has no problem connecting to the Core (when on Wifi of course). Normally, I would force close the app, clear cache and sometimes data and then it would start successfully.

Are there any application logs that I could retrieve to try and diagnose the issue? The Android app I use is the latest one available from the Play Store.

Hi @Mladen_Males and welcome to the Roon forum. Sorry to hear that your first experience is less than ideal. I’m not support, just another user, but I’ll do my best until the real thing shows. The black startup screen is usually shown when the remote is connecting to the core. As you acknowledge, a cellular data connection alone is of no use for Roon, the remote needs to be on the same network, so wifi only.

Could you say a bit more about your network arrangements, so ISP/router used and what components (core, remotes, endpoints) are connected and how? Do you have another wireless remote, like a tablet? Does this have any problems?

Good luck.

Hi, thanks for reaching out! I run the core on a Win10 laptop, and the network is made up of a Tp-Link wired router, with 2 wireless access points (one Dlink and one Netgear) serving upstairs and downstairs in the house.

I have been a heavy Roon user for the last 6 months and have 3 Windows PCs, 2 Android tablets and 3 family Android phones. All of these devices except my Huawei Nova 5t connect pretty much 100% reliably (from both upstairs and downstairs).

One interesting thing to note is that when I am on cellular, the app sometimes gets stuck on the black screen and sometimes it proceeds to the white screen to say “No Wi-Fi”. This is why I thought that my issue happened even before the app attempts to connect to the core. I was hoping that I could turn on some logging in the app, and send over logs to the support team.

Hi @Mladen_Males & @support,
My Samsung Galaxy S9+ phone shows exactly the same problem, and I mean exactly. Also the things I tried to solve it myself are almost similar including trying to find or generate a log.
My wifes Samsung Galaxy S6, my son’s Sony xperia xz premium, an older Samsung tablet Tab S2 all run flawlessly on Android. Also an Ipad mini runs fine. The core and all other devices run on the newest software.
Before the upgrade to 1.8 all devices ran ok, including the S9+
I’m really curious with what solution Roon comes up !!

1 Like

Hi. I have same problem using Huawei P30 Pro. Before upgrading to 1.8 everything worked just fine.

1 Like

It’s comforting to see that I am not alone with this problem :slight_smile:

My problem also started when the 1.8 upgrade was rolled out.

1 Like

I’ll chime in here as per other threads on this issue.

I also have the same issue on 3 devices:
2 x Huawei mate 10 pro
1 x Huawei media pad.

Only started happening with 1.8.

As stated above, am also looking forward to what @support do here. But from reading other threads I have not seen them even acknowledge the issue yet.

While Huawei phones are popular, there’s too many on this list to be a coincidence (just the one Samsung). Is there something non-standard with network connection/discovery on these devices?

Hi @Mladen_Males,

Thanks for sharing the issue you’ve ran into - sorry about the trouble. I am glad to see that you’re engaging with our community. One of our technicians will reach back on this thread as soon as possible.

Thanks in advance for your patience :pray:

@beka thanks for your help. I look forward to hearing from your technical team.

1 Like

Thanks Killdozer for joining my other thread with this one (Android remote app doesn't work - #2 by killdozer).

This is a similar issue to the one I’m seeing on my Samsung Note 20, Note 9 and Tab A.

1 Like

Hello @Mladen_Males ,

Can you please see if the suggestions that worked for @Alex_Benson also help in your case?

If those suggestions don’t help, can you please share a screenshot of the issue which shows the time + date the issue occurred at? Thanks!

I do not think Nova 5t supports a randomised MAC. If it does, there is no setting to disable it then. I have tried all the other things, battery optimisation, autostart, etc to no avail. Here is a screenshot when the problem occurs showing time in Perth, Australia timezone (UTC+8).

. The date is today, 16th of March.

hi @Mladen_Males, you can double-check the randomised mac thing for your model/version of android here:

It’s quite possible you’re right, and you’ve looked here, just making sure.

I followed those steps, and I do not think Nova 5t supports randomised MAC.

1 Like

Exactly the same is happening on my Samsung Galaxy S9+, almost on a daily basis. The app does not open and freezes on the black screen. This never ever happened before 1.8. I have to reboot my phone to get the app to start, rebooting the phone resolves the issue every time. Force stopping the app does not work. When using my Windows 10 PC , the app opens every time , so the issue is with my my phone, which is what I use as my remote. This is very frustrating and is marring my experience with Roon. Connectivity issues should be addressed as a matter of urgency.

I’m having the same issue with a Samsung Note 9 (and a Note 20 and a Tab A).

Last week I was getting issues opening the app very regularly, but with some good advice in the linked post managed to resolve some of the issues in the linked post. Android remote app doesn't work

About 20% of the time I still get stuck on the roon logo on startup - I reckon the android app is just a bit flaky and hasn’t been tested properly. They pretty much say as much on the website -

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Hello All,

We are tracking this behavior in the following thread, if you are still seeing this occur, please let us know here:

Thank You!