Android app having trouble finding Linux Core

No issues for the last 2 days with my Nexus 6P after turning off the IGMP Snooping. Opened and closed the app multiple times, re-started phone multiple times and it snaps right up.

FWIW I have 2 iPads, 1 Surface Pro and a Win 10 desk top (hard wired) that have no issues at all on the same infrastructure.

Ubuntu 16.04 LTS running the Core.

Well, disabling IGMP snooping stopped helping with my Pixel 2’s Core connectivity. For a couple of weeks it would always work, sometimes after a bit of lag in connecting. Since yesterday, back to nothing, except just after I rebooted my network for a router firmware upgrade. Also Ubuntu 16.04 for Core.
Update: Rebooted my Core NUC to install a kernel update, Pixel 2 talks to it now. If past is any guide, when I get back home tomorrow from work, it might no longer connect. I’m really convinced that some multicast weirdness makes Core (or some Linux network state it depends on) get stuck in a mode that is interpreted by the Core as saying that the Android remote is AWOL. That was my early original hypothesis when I studied logs carefully, but Roon engineers could not find a clear culprit.

I run into this problem fairly regularly. I’ve noticed it happens when I put my phone (Galaxy S7 Edge) to sleep while the Roon app is running. I suspect the phone is cutting off wifi for the Roon app (I once saw a “Connecting to Wifi” message when I unlocked my phone before encountering this issue) and that Roon is then unable to find the Core for whatever reason.

My Nexus 6P has been rock solid (no pun intended) as has been my Wife’s Pixel 2. So at least in my case it was the IGMP snooping setting. So thanks @Fernando_Pereira for pointing out the fix. I was resigned to dragging the iPad around with me from room to room.

Cheers.

Richard.

Glad it’s been working for you! It mostly works for me now, but I had to reboot my network and Core server once.

I have evaluated Roon for 2 weeks now, and have the same problem.

The Roon app on my Samsung S8+ (with all updates) always fails to connect (Initializing…) to the core (running on a i7 NUC, Arch Linux) after a few times of turning the display on/off. It’s fine on my apple devices.

I’m running a Ubiquiti Unifi network, with one USG, two routers, two AP’s and one lonesome Netgear GS108T.
IGMP snooping is off.

As the S8+ is my main device, this is quite frustrating…

Edit: the other major bug I found was libraries disappearing, but that is for an other thread.

My network has some similarities with yours (Ubiquiti router and AP, Netgear GS108, Linux NUC core), and I had the same problem with my Android devices until I turned until IGMP snooping off on the GS108. I did have to reboot my net once to regain Android to core connectivity, but it’s been working for several weeks now.

Yes, but it has never been activated here, so unfortunately it must be something else:

Do you have the latest Netgear firmware?

I don’t know, haven’t checked. But since I’m not using IGMP Snooping, it shouldn’t matter.

But when I have the time I’ll check and update if necessary.

Since we don’t fully understand this problem, it may be worth updating the switch firmware to see if it makes a difference. The firmware on my GS108Ev3 (different model from yours) is 2.00.12.

Ok, updated a few days ago.
I haven’t done any extensive testing, but starting the Roon app a few times on and off for a couple of days, and so far no problems.
Weird if this was the case, as only one client is connected to this switch via cable (and the switch is directly connected to the USG). Perhaps it still could mess up the whole network?

Anyway, I will update this thread after some extensive testing.

Since this update I’m having problems. Can you please send me a link to the old Synology Package. The problem is very difficult to connect tablets for use as remote over wireless. Unless I reboot your package every time. I have reinstalled Synology OS software, reset router and every thing possible as i’m a complete geek!?

I suspect this has other causes as the SPK as there is no change in the installation routine or in the launch process.
What kind of remotes did you use? Are there other changes for example in your network topology (or some other software updates on any of the involved devices)?

Hi Christopher, I think the SPK is good. As I have been doing a lot if tests, I borrowed a new Synology DiskStation DS918+, from a shop that I know very well. Installed everything correctly as per instructions and the problem is the same.
I removed all the switches on the network …… Still the same …… I fitted a new rooter … still the same.
However our tablets around the house are all Android Lenovo 10” pro and 8” also tested Samsung S7 and S6. None of them connect.
However I borrowed an iPhone S8 from my son and it connected every time and so did his apple iPad. The Apple app worked perfectly. So the problem is the Android app as I changed everything else to do with Roon.
We are in the UK and Roon is viewed by many people (Manley Musician & artists and so on) in our London offices. We only have Android apps We are MGXmusicUK.
Can someone please fix this as once again the promised Roon is scrap to us as we cannot use it….
One another note the only problem with the SPK is when I add a new album in roon’s music folder I only get the first song added until I reboot the app in the Synology, only then I see the full album…. This happens every time like clockwork. inc the DiskStation DS918+, Any solutions? I think it’s a refreshing problem.

Regarding only the first track showing when adding a new album, I have a similar problem that started with 1.3 and continues to this day. Every time I add an album to the Watched Folder only the first track or two will display.

My work around is to have two folders in my Music Folder (designated as the Watched Folder). I add the album to the first folder (and Roon only shows first track or two). I then transfer it to the second folder (where all my albums reside). As soon as I do this Roon picks up all the tracks. This is easier than rebooting the Roon Core (which also works).

The folks at Roon (and Salk Sound, the maker of my streamer) have been unable to duplicate this behavior, so have been unable to identify and fix the problem. :frowning:

Fortunately my work around is simple and quick, but annoying nonetheless.

Hi Christopher fixed this last night. Go to this page and download the new SPK
Many thanks for your advice
Mario

https://community.roonlabs.com/t/i-moved-your-post/39598

@mike: How is the work going to remove this bug? It’s been almost two years since it has been reported for the first time.

I wanted to say belated thanks for this suggestion:

I have found a similar thing works. By default, wifi is off on my Core (because I’m using the ROCK on a dedicated Intel NUC). I can restore the connection on my Android remote by simply switching wifi on the ROCK to “on” - without so much as trying to enter the wireless network info, or hitting save(!). I’ve been able to reproduce this a few times so this seems like a viable workaround. What it means, I hope @Eric can deduce.

This problem appeared yesterday in my installation for the first time. Im running Roon Core on an Intel NUC with Ubuntu 16.x. I rebooted the Roon Core and after this reboot some of my android devices have not been able to connect to the Core since then.

  • My Apple (iphone) device still works
  • My Windows Roon Client still works
  • Roon App on Android 7.x tablet still works
  • Both Roon Apps on two Android 6x devices don’t work (it’s an old Nexus 10 tablet and a Sony Xperia Compact Z3 phone)

I tried to turn off/on the WiFi, turned on flight mode, rebooted Android device and reinstalled Roon Remote. Nothing helped.

My network installation is rather straight forward. Everything is on the same subnet. The router is handling DHCP requests. I have two UniFi APs for WiFi. I have various multimedia services running in the network (OpenElec, NAS, Sonos, UPnP Server, Philips Hue, etc…) All of these services are working as usual.

I’ll continue to investigate tonight…