Android devices can't connect to Core after update

Core Machine (Operating system/System info/Roon build number)
Windows 10/Version 1909 – ASUS Laptop/Intel Core i5/8GB RAM – Roon 1.7/521

  • Lenovo Tab M10 (Android 9)
  • Moto G5 Plus (Android 8.1)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
TP Link Cable Modem/Cisco Switch/Wireless and Wired
Wifi on the same network for Android.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
PS Audio Gain Cell DAC/Sonore Ultra Rendu/USB connections

Description Of Issue
Unable to use Lenovo Android Tablet following 1.7/521 update

Neither my of my Android remote can access Roon, and both worked perfectly prior to the update to Build 521. They can make the connection to the core, then freeze.

Hi @Tom_Gibbs1,

Our team is currently investigating this issue and we are hoping you can provide some additional details:

  • Is there any change if you reboot the devices and your Core machine?
  • Is there any change if you reinstall the app on these devices?


There is no change with a reboot to either my laptop (which contains Roon’s core), or a reboot to either of the Android devices.

I have uninstalled and reinstalled the apps on both devices with no change to their behavior.


Thanks for the confirmation, @Tom_Gibbs1. The team is looking into this and we will be sure to update you as soon as we have more information.

In the meantime, if you’d like to perform an additional test, I’m hoping you can do the following:

  • Make a backup of your Roon database
  • Go to Settings > Storage on your Windows device, select the 3 dots button next to each watched folder, and choose Disable
  • Reboot one of the Android devices and try to connect once more

Is there any change after doing this?

I made a backup as requested, then disabled the storage as instructed. I then rebooted my Android phone.

The Android phone would then connect to Roon’s core with no problems. It gave me the message that I needed to connect to my storage device, which I did, and everything seems to work OK. I then backed out of Roon, and restarted the app to see if it would continue to work, and it appears to be working properly now. I’m headed downstairs to reboot the Android tablet; unless I respond, you can assume that it worked as well.



Nope. Still no luck with the Lenovo Android tablet.

Hi @Tom_Gibbs1,

Thank you for the update. We are still investigating this behavior and we will post status updates in the following thread:

We have been able to reproduce this issue in the lab today and are making progress on this issue, I appreciate your patience during this ongoing investigation.


Description Of Issue
Still unable to use Lenovo Android Tablet following 1.7/521 update

Any news?

Hi @Tom_Gibbs1,

Thanks for reaching out again. There’s no new information at this time, we are still investigating this behavior and it will require a new Roon release to address it.

The devs are working hard on this release, but this release contains a few more fixes than just the Android issue and we are hoping to ship a couple of fixes together at the same time.

We appreciate your patience while this work is underway, any status updates will be made on the above linked thread or mentioned in the Release Notes Section of this site once the release is published.

Thank you!


We’ve released a new update, Roon 1.7 Build 528, which contains improvements that we believe will help with the issues you are experiencing here. Please see our release notes below:

The Team At Roon Labs

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.