Android One Device Can't Connect to Core Windows 10 PC

I’m a new subscriber. One feature that sold Roon to me was the ability to control Roon on my core W10 PC with my the Android app on my Android phone. Everything worked fine while trialling the service on the PC and Android app. 2 days ago, my subscription payment went through - and now it’s not working! What the hell is going on?!

Core device: Microsoft Surface Pro 2 w/ 8GB RAM / 256GB storage / using Seagate 1TB drive to access library of FLAC files.
Android Device: Nokia 8 Sirocco running Android One (same OS as Google Pixel 2).

All was working fine until today, then for some reason my android app can no longer connect to the Core. I’ve gone through all the advice on the help section of the app. The Android app is seeing the Core Device - it says “Connecting”, and then “Connection Failed”. Obviously something has changed either in Windows 10 or the Android app since yesterday.

Please could you figure this out and advise. Without the remote app functionality I’m not really sold on the Roon experience - so will be asking for a refund if this can’t be resolved.

Thanks for your time


Hey @Nemo_Halperin,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Do you have any active antivirus or firwalls on the Core machine? If so, can you try temporarily disabling them and let me know if there’s any improvement?

Have you tried rebooting the Core machine since this behavior started?


Hi Dylan, as mentioned; I have already followed all the advice on the support pages. First thing I did was reboot both devices. Yes I have anti virus (Windows Defender) and firewall. I’ve tried connecting with the firewall off on the PC. Not with windows defender switched off. Both devices are connected to a private wifi router in my home (a BT Home Hub / Marvell AVASTAR Wireless-AC Network Controller - provided by British Telecom). The most likely reason that I can think of is something changed either in W10 or the Android One or Roon apps that has stopped the connection of my android device being seamless and instant (it was so good during the trial period!!!). Are you aware of something that changed in a recent update to W10 or the other elements in the chain?

Hi Dylan, inexplicably the fault has resolved. I tried connecting again this morning. Several attempts with reboots. Nothing doing. Then after lunch I tried rebooting both devices yet again - surprisingly this time it connected. I’m feeling uneasy about the fact there was no apparent reason for the fault, and no apparent reason why it resolved. I hope it doesn’t recur.

In the meantime, thanks for your response within 4 hours of posting in the community.

My additional feedback is that supplying a live chat access for tech support to resolve issues would elevate your customer service to the next level if you can afford to implement that access.

Also - there is an absence of dialogue feedback in the Android Roon app and Windows desktop application. If something isn’t working - then error messages would be logical to help subscribers understand into which bucket their fault should be placed and most probably speed resolution of issues. Just having a message telling me “Connection Failed” doesn’t really help diagnose anything.

Many thanks


Hey @Nemo_Halperin,

I’m glad that things are currently working for you. If you see this behavior return please let us know and we can take a closer look at things.

Is there any chance that there was a Windows update around the time that you started experiencing this behavior?


Yes there was a W10 update in the past few days. But if that was the cause why did it resolve without another further update? Thanks

Hi Dylan, another W10 update today. And yes, you guessed it. The Android Roon remote app stopped connecting again. Any advice for me? Thanks, Nemo

Hi Dylan, am waiting for some support as the issue has returned. I’m expecting that your tech support department are abreast of the impacts of W10 updates on how Roon works on W10 and how updates can affect how Android remote app devices connect to the Roon Core. This is what appears to be happening here - so some feedback and reassurance from you would go a long way. My connected question to this is - how often do remote app lock outs like this happen with W10 updates? I think it’s fair to inform your subscribers if you’re aware of an issue and can advise that you’re doing something to resolve it. As I originally mentioned it was the remote app functionality that really sold me on Roon. If I want to play my FLACs by using a desktop app on it’s own I can go back to my JRiver subscription! Many thanks for your time. Nemo

Is the core connected via ethernet cable or wirelessly?

Surely it should work for both shouldn’t it?

There sometimes seems to be a correlation with the android devices not connecting and wireless issues. (Reading the support forum generally)
Roon also recommend that you connect the core wired if possible. When I had powerline adapters I often had connection issues and moving to a mesh network solved that.
Not saying this is your issue but networks are often problematic for roon; often roon doesn’t ignore problems the same way as other software. (Or roon is pickier/worse - whichever way you see it)

Thanks for your input Ged. I’ll wait for someone from Roon Support to give me some answers. My setup is the opposite of complicated. One broadband hub. One laptop connected to the broadband wirelessly. One harddrive connected via USB to the laptop. Everything worked fine and seamlessly for 14 days during my trial period so my understanding is that Roon was working fine prior to some W10 updates. If the Roon Tech Support are keeping up with W10 updates and any issues that result from them my expectation is that someone in support should be able to advise on what may be causing the issue. Hopefully someone will respond soon. I’ve been waiting 36 hours now. Thanks, Nemo

Hey @Nemo_Halperin,

Windows updates don’t typically cause any major issues with Roon. The October Windows update originally had some general issues (not specific to Roon), but otherwise the most common symptom that we see from Windows updates is that sometimes firewall settings can be reset if exceptions had been made for Roon and RAATServer.

As Ged suggested above, often times remote connection issues can stem from networking troubles. If you connect your Core machine via Ethernet instead of WiFi (we always recommend this for optimal performance). Let me know if there is any change when you connect via Ethernet.


Hi Dylan, the router is 10m away and across a hallway. I can not connect via ethernet. I thought that Roon was a network solution. By that I mean it works wirelessly in a network. What is the point in this day and age of having a software that prefers or depends upon an ethernet connection. I expected a more helpful answer. Please could you explain what other convoluted things you’d like me to do to try and get the Roon remote working again. Surely it should just work fine wirelessly as it did while I was in the trial period? Thanks

Hey @Nemo_Halperin,

While I understand that it may not be a permanent solution, temporarily relocating the Surface Core machine to connect via Ethernet and seeing if there is any change will help us further narrow down where this behavior may be stemming from.

Besides the Nokia device, do you have any other devices (iOS, Windows, Mac) that you can try to use as a remote device? Knowing whether or not this behavior is limited to the Android device or not will also help us further understand why this behavior may be occurring.


The W10 update then it doesn’t work seems to indicate a W10 problem. Have you checked windows firewall settings?

Hi Dylan (@dylan),
Thanks for your suggestions as they are more constructive. I would have tried the direct ethernet connection already. But I’m using a Surface Pro 2 which doesn’t have an ethernet port. I could buy an adaptor, but to be honest, that does kind of annoy me - because your software was working perfectly during the trial phase. I believe that your software is designed to work wirelessly and that something has changed - most probably due to W10 updates, so do you agree with Ged’s theory? The only smartphone I have in the house is my Android Nokia 8 Sirocco which runs the same OS - Android One - as the Pixel 2 which you recommend as being the most ideal choice for connection to Roon with the Android remote app. So any more ideas?



Just a data point here, but I have a Nokia 7 Plus running Android One (8.1.0) that is running the Roon Remote flawlessly. But then, I have my Core running on an Intel NUC with ROCK.

Just to test, I also have a Core running on a Windows 10 laptop, and that is now running Windows Build 1809. And interestingly, my Roon Remote on my Nokia Android One phone cannot see the Core running on the Windows laptop - only the Core running on ROCK… I’ve checked the firewall setting on the laptop, and both Roon and the Roon Appliance EXEs have settings to allow communication through the firewall.

However, rebooting the laptop has cured the issue, and now the Nokia is happily communicating with the Core on the Windows 10 laptop…

Nemo, I just tried a Nokia Android One phone, the 6.1, and it works fine over the home WiFi to talk to my core (which is an underpowered Core 2 Duo Mac Mini running Ubuntu). So I don’t think it’s your phone. Oh, and my network is somewhat patchwork, using powerline Eithernet to connect the core to the router, but it all works fine.

Thanks Geoff and Bill for your feedback on your Android One phone experiences. I’m running W10 v1803. Updates installed over past few days have been Quality Updates on 10/10/18. Intel Driver Updates on 12/10/18. Windows Defender Definition Updates on all preceding days. I’ve rebooted both Surface Pro 2 and Nokia 8 Sirocco several times and the fault has not resolved (that did happen though a few days ago after a W10 update, but since the most recent one the fault has recurred). I’d like to understand what is causing this issue on the W10 side. Again, it is puzzling because during the trial it could not have been working more perfectly.

1 Like