Android phone unable to connect to Core on Nucleus

I have just set up a new Router (BT Smart Hub2)
The Nucleus connected immediately, as did my iPad and iMac. However, my Samsung S20, Android phone is just not having it. I deleted and reinstalled the Roon app, but it still won’t connect to the phone.

Under help, I saw “Accept Remote Connection”. However I cannot find that setting anywhere? Can anyone please help me to connect my Android phone? Thanks

When you wait for your phone to connect, does a Help button show up (after some time maybe)? Click on it and try with entering the IP-Address This often does the trick.

1 Like

Bingo! It worked. Thank you @BlackJack

Why did it need that?

Some flavors of Android, and AFAIK Samsung is one of them, have issues with broadcast/multicast traffic and need a little “help”.

1 Like

Thank you👍

Just as a point of interest, where is the setting “Accept Remote Connections”?


In Roon Settings|Setup according to the documentation, but I also never seen it. Maybe because of:

The option is just not there because you, running your core on a Nucleus, don’t need that option (it is automatically on).

1 Like

Thank you @BlackJack :+1:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.