Android Remote does not connect to Core since last update

Since the last update of Ronn Remote on Android, my Android hardware isn’t uable to connect to the Core. All iOS and Mac Hardware is working fine. So the setup should be OK.

Any ideas ?

Thanks for your help and regards

Hi @Daniel_Mangili,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Since the update have you tried rebooting your Core machine and the remote device?

I had the same problem, but only only on 5ghz as soon as I switched my android device to 2.4hhz I connected every time. And yes it doesn’t make any sense but it worked for me.

Hi Sony,
thanks for your help.
I tried on 2.4GHz, but it did not help.
Strange, iOS and OSX is working fine. But all Androids, including Chromebooks do not work anymore.

Thanks for your help and kind regards

Hi @Daniel_Mangili,

Can you describe your current networking setup?

If you use an app like Fing on the Android devices are you able to see the Core machine?

Hi Dylan

Thnaks for yout help, i´m using:

Roon Core Device (Wired direct to the rooter):

  • i7 Hardware with Ubuntu 18.04 LTS
  • Installation was without any issues or problems

Roon Control Devices (WLAN , 2.4 GHz)

  • Apple iPod (Works great, finds core immediately)
  • Apple iMac (Works great as well)
  • Fairphone 2, Fairphone Open (Android 6) (Did work, but can´ find core anymore)
  • ASUS Chromebook (Did work as well, now same issue like Fairphone)

Roon Endpoints (WLAN 2.4 GHz):

  • Auralic Aries / Wadia Intuition (Works great)
  • Chord Poly / Mojo (Works great)
  • Fairphone 2 (Stopped working)

I installed FING on the Fairphone, The core is visible.
This are the results:

  • PING: No Packets lost, Average Time: 5ms
  • Zero hops,
  • Ports used:
    – 22 ssh (Yes, a SSH-Server is installed)
    – 5900 vnc (Yes, VNC is installed)
    – 9100 jetdirect (There is no jetdirect adapter installed, is this roon core?)
    – 9101 jetdirect (Like 9100)

Anything more that could help ?

Thanks for your help

Hi @Daniel_Mangili,

I appreciate the setup information here. We are investigating an issue where some users are experiencing difficulty connecting Android devices to a Linux Core. That may be what you’re experiencing here. There are some things we can try here to determine whether or not that is the case.

If you temporarily use your iMac as the Core machine are you able to connect your Android device to it?

What router are you currently using? Are you making use of any switches?

Hi Dylan

i did set up the iMac as Roon Core. All the devices, including the Androids are able to connect now immediately and work without an issues. Great !

The router is the the “Sunrise Internet Box”. It’s the standard internet gateway from sunrise.
I do not use any other routers or switches.

Thanks for your help and kind regards

Hi @Daniel_Mangili,

Thank you for giving that a try. Based on the testing and the symptoms, it seems as though you are experiencing the Linux/Android issue that I previously mentioned where some Android devices have trouble communicating with some Linux Cores.

In the past, some users have seen improvement by modifying their networking setup. In general, we typically advise against ISP provided networking hardware. While that may be worth a try, some users remain affected by this issue regardless of their networking setup. This is something that we are always investigating. I’ll be sure to let you know if there are any changes here.